Exclude from compile

I have a directory structure of

src/appA
src/appB

When I have appA project open I don't want to compile appB. I have exclude folders from the project properties and from the compiler settings.

My exclude from contents the exclude is grayed out (see pic)

In any case it's not working, and it use to prior to 823. Can anyone help.



Attachment(s):
ideapic.jpg
18 comments
Comment actions Permalink

If you want to exclude from compilation only, you don't need to exclude the files from project - you should exclude only from
Compiler Settings tab.

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"



0
Comment actions Permalink

I have it in the exclude from compile also but that doesn't seem to be working. Is there another setting somewhere that could be over-riding this one?

0
Comment actions Permalink

I am a little surprise here that you guys are not working on it. There are 2
bugs opened on that problem.
http://www.intellij.net/tracker/idea/viewSCR?publicId=13199
http://www.intellij.net/tracker/idea/viewSCR?publicId=13399

Jacques

"Eugene Zhuravlev" <jeka@intellij.com> wrote in message
news:bckrna$st0$1@is.intellij.net...

If you want to exclude from compilation only, you don't need to exclude

the files from project - you should exclude only from

Compiler Settings tab.

>

--

>

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

>
>
>


0
Comment actions Permalink

I am a little surprise here that you guys are not working on it. There are 2
bugs opened on that problem.


Now that a half of the team is back from JOne the things will go faster :-). And if it is really a bug, it will be definitely fixed.

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"



0
Comment actions Permalink

heh, where's the other half? LOL

R
"Eugene Zhuravlev" <jeka@intellij.com> wrote in message
news:bcn2i8$47k$1@is.intellij.net...

I am a little surprise here that you guys are not working on it. There

are 2

bugs opened on that problem.

>

Now that a half of the team is back from JOne the things will go faster

:-). And if it is really a bug, it will be definitely fixed.
>

--

>

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

>
>
>


0
Comment actions Permalink

BTW, I did not manage to reproduce these bugs. Any additional hints to reproduce? (see my comments to the SCRs)

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"


"Jacques Morel" <jacmorel@yahoo.com> wrote in message news:bcm3ra$dm4$1@is.intellij.net...

I am a little surprise here that you guys are not working on it. There are 2
bugs opened on that problem.
http://www.intellij.net/tracker/idea/viewSCR?publicId=13199
http://www.intellij.net/tracker/idea/viewSCR?publicId=13399

>

Jacques

>

"Eugene Zhuravlev" <jeka@intellij.com> wrote in message
news:bckrna$st0$1@is.intellij.net...

If you want to exclude from compilation only, you don't need to exclude

the files from project - you should exclude only from

Compiler Settings tab.

>

--

>

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

>
>
>

>
>


0
Comment actions Permalink

I find that I can exclude directories, but that I cannot exclude individual files. When the compile errors appear I can right click on the error and exclude the file. The file appears on the excludes list but next time I make the project the file gets compiled again.

0
Comment actions Permalink

On Tue, 17 Jun 2003 16:46:00 +0400, Eugene Zhuravlev wrote:

>> I am a little surprise here that you guys are not working on it. There
>> are 2 bugs opened on that problem.


Now that a half of the team is back from JOne the things will go faster
:-). And if it is really a bug, it will be definitely fixed.


In order to compile and run my project that has NetBeans .form files in
it, I've had to add the exclude under the main Idea settings dialog, its a
pity this isn't set at a project level :(

--
...turn to the light - don't be frightened by the shadows it creates,
...turn to the light - turning away could be a terrible mistake
...dream theater - the great debate


0
Comment actions Permalink

+If you want to exclude from compilation only, you don't need to exclude the files from project - you should exclude only from
Compiler Settings tab.
+
I have a project which contains a lot (thousands) of files in the project directory which I don't want Idea to look at at all (generated javadocs, other documentation, copies of the source tree automatically modified for JDK 1.1, regression test data, test results etc.), as they really slow down the project loading, optimizing, index generation etc. it would be really nice to be able to exclude directories from the project, as well as just compilation

0
Comment actions Permalink

This is probably because the excluded class is used by another class which is passed to compiler. Could this be the case?

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

"Declan Flynn" <no_mail@jetbrains.com> wrote in message news:1899900.1055925147480.JavaMail.itn@is.intellij.net...

I find that I can exclude directories, but that I cannot exclude individual files. When the compile errors appear I can right

click on the error and exclude the file. The file appears on the excludes list but next time I make the project the file gets
compiled again.


0
Comment actions Permalink

loading, optimizing, index generation etc. it would be really nice to be able to exclude directories from the project, as well as

just compilation

Excludes that are available in "ProjectProperties | Main Module | Contents" tab do exactly this.

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"


0
Comment actions Permalink

it, I've had to add the exclude under the main Idea settings dialog, its a
pity this isn't set at a project level :(


AFAIK compiler excludes are managed on the project level. What do you mean by "main Idea settings dialog"?



0
Comment actions Permalink

On Wed, 18 Jun 2003 15:07:04 +0400, Eugene Zhuravlev wrote:

AFAIK compiler excludes are managed on the project level. What do you mean
by "main Idea settings dialog"?


Under the compiler excludes I can select a path, not wildcard. So I added
*.form in the "IDE Settings->General->Ignore files and folders".

Mark



--
...turn to the light - don't be frightened by the shadows it creates,
...turn to the light - turning away could be a terrible mistake
...dream theater - the great debate


0
Comment actions Permalink

The problems with form files of different format are already solved and will be available in the next pubic build

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"


"Mark Derricutt" <pinhead@satinism.org> wrote in message news:pan.2003.06.19.06.29.59.185681@satinism.org...

On Wed, 18 Jun 2003 15:07:04 +0400, Eugene Zhuravlev wrote:

>

AFAIK compiler excludes are managed on the project level. What do you mean
by "main Idea settings dialog"?

>

Under the compiler excludes I can select a path, not wildcard. So I added
*.form in the "IDE Settings->General->Ignore files and folders".

>

Mark

>
>
>

--
...turn to the light - don't be frightened by the shadows it creates,
...turn to the light - turning away could be a terrible mistake
...dream theater - the great debate

>


0
Comment actions Permalink

On Thu, 19 Jun 2003 13:18:58 +0400, Eugene Zhuravlev wrote:

The problems with form files of different format are already solved and
will be available in the next pubic build


Cool, looking forward to seeing the new build. Are the XML files speficy
a DocType now?

--
...turn to the light - don't be frightened by the shadows it creates,
...turn to the light - turning away could be a terrible mistake
...dream theater - the great debate


0
Comment actions Permalink

this use to work before 823, it's KILLING me now. We have lots of different projects and every time I compile any of them it parses every .java file. It makes builds very slow

0
Comment actions Permalink

Could you create a small test project, that reproduces the problem and send it (ipr, iws, sources) to me directly?

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"


"charles decroes" <spam@decroes.com> wrote in message news:19943008.1056035190967.JavaMail.itn@is.intellij.net...

this use to work before 823, it's KILLING me now. We have lots of different projects and every time I compile any of them it

parses every .java file. It makes builds very slow


0
Comment actions Permalink

I found the option here in Intellij Community Edition 2018.3 version of IDE

0

Please sign in to leave a comment.