Using Ant managed project in Intellij 7 M2

Hi,

I have a project with several subdirectories under the main directory, I'm using ant now to manage the build, is there a way to import this into Intellij ? Thanks.
A.C.

3 comments
Comment actions Permalink

Hello Angelo,

I have a project with several subdirectories under the main directory,
I'm using ant now to manage the build, is there a way to import this
into Intellij ? Thanks.


Well, you can just specify the location of the sources in the IntelliJ IDEA
new project wizard, and then add your Ant build script if required. There
is no way to import the location of the sources from an Ant script automatically.

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

hi,

Thanks for quick reply, I have this project with this structure:

/tutorial/src
/tutorial/lib
/tutorial/web.xml
/tutorial/src/hibernate.cfg.xml

IDEA recognize only src directory and creates two facets namely web and hibernate. when I run the servlet configuration, it always says that :

out/exploaded/tutorialWeb not found for the web module, if I click ok, it runs perfectly, but can't find a way to remove that warning. any hint? Thanks.

A.C.

0
Comment actions Permalink

Hello Angelo,

The path out/exploaded/tutorialWeb is probably may be found in your web facet
settings, "Java EE Build" tab, "Exploded directory" field.
Usually IDEA creates it with no problem on module compilation. You can try
compile module first, or change this setting, or check what's happen on your
hard drive (maybe some permissions required or anything).

hi,

Thanks for quick reply, I have this project with this structure:

/tutorial/src
/tutorial/lib
/tutorial/web.xml
/tutorial/src/hibernate.cfg.xml
IDEA recognize only src directory and creates two facets namely web
and hibernate. when I run the servlet configuration, it always says
that :

out/exploaded/tutorialWeb not found for the web module, if I click ok,
it runs perfectly, but can't find a way to remove that warning. any
hint? Thanks.

A.C.

Alexander.


0

Please sign in to leave a comment.