CVS and SourceForge

Hello,

Can anybody explain how to use CVS integration with SourceForge over SSH?
I have read lot at IntelliJ TWiki but still have no results.

Anybody have expertise with worked CVS on SourceForge from IntelliJ?

Thanks!

--
Alexey Efimov, Software Engineer
Sputnik Labs,
http://www.spklabs.com


6 comments
Comment actions Permalink

Hello!

It's simple. If you have installed SSH, use following server description in
IDEA:

:ssh:login@cvs.sourceforge.net:/cvsroot/path

And enter your password when IDEA ask you about it.


--
Best regards,

Stanislav Davydov
JetBrains, Inc

"Alexey Efimov" <aefimov@spklabs.com> wrote in message
news:bcuuel$fs6$1@is.intellij.net...

Hello,

>

Can anybody explain how to use CVS integration with SourceForge over SSH?
I have read lot at IntelliJ TWiki but still have no results.

>

Anybody have expertise with worked CVS on SourceForge from IntelliJ?

>

Thanks!

>

--
Alexey Efimov, Software Engineer
Sputnik Labs,
http://www.spklabs.com

>
>


0
Comment actions Permalink

Can you control?

I set in project properties CVS integration.
Then go to Tools->Check out project
Then press button "...", then "Add"
Cvs root: :ssh:login@cvs.sourceforge.net:/cvsroot/path
Use branch: mymodule
Enter password: *****

IntelliJ says "Connection success!"
I close window, becose button "Checkout project" still disabled...

I select one file and do CVS->Update, Intellij hangs up... until i kill ssh
process

BTW, before i used :ext:login@cvs.sourceforge.net:/cvsroot/path, not :ssh:,
IntelliJ not prompt me for password, but ssh process is invoked.

--
Alexey Efimov, Software Engineer
Sputnik Labs,
http://www.spklabs.com
"Stanislav Davydov" <stathik@intellij.com> wrote in message
news:bcv0d0$ksi$1@is.intellij.net...

Hello!

>

It's simple. If you have installed SSH, use following server description

in

IDEA:

>

:ssh:login@cvs.sourceforge.net:/cvsroot/path

>

And enter your password when IDEA ask you about it.

>
>

--
Best regards,

>

Stanislav Davydov
JetBrains, Inc

>

"Alexey Efimov" <aefimov@spklabs.com> wrote in message
news:bcuuel$fs6$1@is.intellij.net...

Hello,

>

Can anybody explain how to use CVS integration with SourceForge over

SSH?

I have read lot at IntelliJ TWiki but still have no results.

>

Anybody have expertise with worked CVS on SourceForge from IntelliJ?

>

Thanks!

>

--
Alexey Efimov, Software Engineer
Sputnik Labs,
http://www.spklabs.com

>
>

>
>


0
Comment actions Permalink

Oops, its work, sorry, i must not use branch.
Then i clear this option CVS integration come work ok.

I try to make some guides at TWiki site about it, thanks!

--
Alexey Efimov, Software Engineer
Sputnik Labs,
http://www.spklabs.com
"Alexey Efimov" <aefimov@spklabs.com> wrote in message
news:bcv1c5$oh0$1@is.intellij.net...

Can you control?

>

I set in project properties CVS integration.
Then go to Tools->Check out project
Then press button "...", then "Add"
Cvs root: :ssh:login@cvs.sourceforge.net:/cvsroot/path
Use branch: mymodule
Enter password: *****

>

IntelliJ says "Connection success!"
I close window, becose button "Checkout project" still disabled...

>

I select one file and do CVS->Update, Intellij hangs up... until i kill

ssh

process

>

BTW, before i used :ext:login@cvs.sourceforge.net:/cvsroot/path, not

:ssh:,

IntelliJ not prompt me for password, but ssh process is invoked.

>

--
Alexey Efimov, Software Engineer
Sputnik Labs,
http://www.spklabs.com
"Stanislav Davydov" <stathik@intellij.com> wrote in message
news:bcv0d0$ksi$1@is.intellij.net...

Hello!

>

It's simple. If you have installed SSH, use following server description

in

IDEA:

>

:ssh:login@cvs.sourceforge.net:/cvsroot/path

>

And enter your password when IDEA ask you about it.

>
>

--
Best regards,

>

Stanislav Davydov
JetBrains, Inc

>

"Alexey Efimov" <aefimov@spklabs.com> wrote in message
news:bcuuel$fs6$1@is.intellij.net...

Hello,

>

Can anybody explain how to use CVS integration with SourceForge over

SSH?

I have read lot at IntelliJ TWiki but still have no results.

>

Anybody have expertise with worked CVS on SourceForge from IntelliJ?

>

Thanks!

>

--
Alexey Efimov, Software Engineer
Sputnik Labs,
http://www.spklabs.com

>
>

>
>

>
>


0
Comment actions Permalink

It's not still working...
Work only Project Check Out, but CVS command like Commit, Update etc hand up
IntelliJ before i kill process ssh.

I have Windows 2000,
CVS 1.11.1.3
JDK 1.4.1_03
Also i have instalation of cygwin with SSH.

From command line all cvs commands work fine, but i must every time enter
the password.

--
Alexey Efimov, Software Engineer
Sputnik Labs,
http://www.spklabs.com
"Alexey Efimov" <aefimov@spklabs.com> wrote in message
news:bcv1c5$oh0$1@is.intellij.net...

Can you control?

>

I set in project properties CVS integration.
Then go to Tools->Check out project
Then press button "...", then "Add"
Cvs root: :ssh:login@cvs.sourceforge.net:/cvsroot/path
Use branch: mymodule
Enter password: *****

>

IntelliJ says "Connection success!"
I close window, becose button "Checkout project" still disabled...

>

I select one file and do CVS->Update, Intellij hangs up... until i kill

ssh

process

>

BTW, before i used :ext:login@cvs.sourceforge.net:/cvsroot/path, not

:ssh:,

IntelliJ not prompt me for password, but ssh process is invoked.

>

--
Alexey Efimov, Software Engineer
Sputnik Labs,
http://www.spklabs.com
"Stanislav Davydov" <stathik@intellij.com> wrote in message
news:bcv0d0$ksi$1@is.intellij.net...

Hello!

>

It's simple. If you have installed SSH, use following server description

in

IDEA:

>

:ssh:login@cvs.sourceforge.net:/cvsroot/path

>

And enter your password when IDEA ask you about it.

>
>

--
Best regards,

>

Stanislav Davydov
JetBrains, Inc

>

"Alexey Efimov" <aefimov@spklabs.com> wrote in message
news:bcuuel$fs6$1@is.intellij.net...

Hello,

>

Can anybody explain how to use CVS integration with SourceForge over

SSH?

I have read lot at IntelliJ TWiki but still have no results.

>

Anybody have expertise with worked CVS on SourceForge from IntelliJ?

>

Thanks!

>

--
Alexey Efimov, Software Engineer
Sputnik Labs,
http://www.spklabs.com

>
>

>
>

>
>


0
Comment actions Permalink

I'm not give the option to use :ssh: within IDEA. It lets me use :ext:
It was working for me with TortoiseCVS, but I upgraded TortoiseCVS and
now it doesn't work, but does in WinCVS.

How am I supposed to specify :ssh:?

Dave Forslund

Stanislav Davydov wrote:

Hello!

It's simple. If you have installed SSH, use following server description in
IDEA:

:ssh:login@cvs.sourceforge.net:/cvsroot/path

And enter your password when IDEA ask you about it.


0
Comment actions Permalink

tried. It doesn't work. It gives me an error

"Invalid public key or data"

But this is exactly the same public key is used when I used :ext: and pagent.

0

Please sign in to leave a comment.