CVS wrong method - what's wrong?

when I try to use CVS support with 8xx (also 833)
all I get is "L:\CVSRepository wrong method" when
doing "check out project"

L: is a connected network drive where the CVS repository
is located.

what could be the problem?

13 comments
Comment actions Permalink

Looks like you need to provide more information (e.g. a step-by-step
explanation, what exactly you did).

Tom

0
Comment actions Permalink

Maybe I should say that CVS works perfectly with IDEA 3.x.
I use (one of) the newest CVS client for windows, I'm running on XP.
In Idea 833 I select project properties, VCS support: CVS, edit nothing there, cvspass points to C:\Dokumente und Einstellungen\Michael\.cvspass but I use no .cvspass
(the file does not exist, and with IDEA 3 that worked). Could that be a problem?

next I do CVS->check out project (I assume this is
supposed to be done first?), adding a repository on L:
and then I get "... wrong method"

0
Comment actions Permalink

What repository settings you use?

Tom

On Tue, 24 Jun 2003 07:25:23 +0000 (UTC), Michael Damberger
<michael.damberger@t-online.de> wrote:

>Maybe I should say that CVS works perfectly with IDEA 3.x.
>I use (one of) the newest CVS client for windows, I'm running on XP.
>In Idea 833 I select project properties, VCS support: CVS, edit nothing there, cvspass points to C:\Dokumente und Einstellungen\Michael\.cvspass but I use no .cvspass
>(the file does not exist, and with IDEA 3 that worked). Could that be a problem?
>
>next I do CVS->check out project (I assume this is
>supposed to be done first?), adding a repository on L:
>and then I get "... wrong method"

0
Comment actions Permalink

all defaults, except CVSROOT/cvswrappers was changed so
that files ending with .gif, .doc, ... are treated as
binary files.
that's all.

0
Comment actions Permalink

No, no -- what is the content of your CVS/Root files?

Tom

On Tue, 24 Jun 2003 08:51:14 +0000 (UTC), Michael Damberger
<michael.damberger@t-online.de> wrote:

>all defaults, except CVSROOT/cvswrappers was changed so
>that files ending with .gif, .doc, ... are treated as
>binary files.
>that's all.

0
Comment actions Permalink

"Michael Damberger" <michael.damberger@t-online.de> wrote:

when I try to use CVS support with 8xx (also 833)
all I get is "L:\CVSRepository wrong method" when
doing "check out project"

>

L: is a connected network drive where the CVS repository
is located.

>

what could be the problem?


Looks a bit like you are using :local: protocol. Since IDEA has its built in CVS
client now, this no longer works because :local: requires server functionality.
Try to install a local cvs server and use :pserver: method to connect to it.

Hope that helps.

Sascha


0
Comment actions Permalink

thank you, I think this is the problem. I'm using :local:

Is there no way to get IDEA 8xx woriking with :local: ?
maybe if I prefix the environment variable CVSROOT
with :local: ?

Because when setting up a server, I need
authentification, too - right?

0
Comment actions Permalink

I don't have the files at hand curently,
but the problems semmes to be using the :local: method
- thank you

0
Comment actions Permalink

>Is there no way to get IDEA 8xx woriking with :local: ?

No, IDEA not has a CVS client; but :local: needs server
functionality.

>maybe if I prefix the environment variable CVSROOT
>with :local: ?

The environment variable is never used.

>Because when setting up a server, I need
>authentification, too - right?

Yes, try CVSNT with pserver - its very easy to setup.

Tom

0
Comment actions Permalink

got the files now via email:
this is content of .#config, what else is interesting?
(it are quite a lot of files).

  1. Set this to "no" if pserver shouldn't check system users/passwords

#SystemAuth=no

  1. Put CVS lock files in this directory rather than directly in the repository.

#LockDir=/var/lock/cvs

  1. Set `TopLevelAdmin' to `yes' to create a CVS directory at the top

  2. level of the new working directory when using the `cvs checkout'

  3. command.

#TopLevelAdmin=no

  1. Set `LogHistory' to `all' or `TOFEWGCMAR' to log all transactions to the

  2. history file, or a subset as needed (ie `TMAR' logs all write operations)

#LogHistory=TOFEWGCMAR

  1. Set `RereadLogAfterVerify' to `always' (the default) to allow the verifymsg

  2. script to change the log message. Set it to `stat' to force CVS to verify# that the file has changed before reading it (this can take up to an extra

  3. second per directory being committed, so it is not recommended for large

  4. repositories. Set it to `never' (the previous CVS behavior) to prevent

  5. verifymsg scripts from changing the log message.

#RereadLogAfterVerify=always

0
Comment actions Permalink

I'll try on Friday,
maybe it should even work without auth:

  1. Set this to "no" if pserver shouldn't check system users/passwords

#SystemAuth=no


btw., it would be nice if IDEA 8xx would work
with :local:, too ;)

0
Comment actions Permalink

ok, I think you meant sth. else:
content of CVS/root file is the path to repository
taken from the environment variable CVSROOT at the
time of checking out:

L:\CVSRepository

0
Comment actions Permalink

"CVS wrong method - what's wrong?"
--- the method ;o)

0

Please sign in to leave a comment.