Pauses and cpu utilization with every keypress in editor (#823)

Any idea how to reduce IDEA's cpu utilization while typing? Every letter I type spikes the cpu, and if I'm typing at a normal speed, the cpu is totally pegged, and there's a pause between each letter typed.

I'm typing in a very small file (an interface which just 14 lines so far), I've turned all popup hints, turned off autopopup code completion, increased the autoreparse delay to 1000 ms, turned off local vcs, turned off anti-aliased fonts, turned off the concurrent garbage collector, and turned off cvs integration. Nothing seemed to help. Oh, and no, I'm not working on files on a network drive.

Any advice/explanation?

1 comment
Comment actions Permalink

I think I figured it out. If you type a line which is wider than the editor, then each additional letter you type takes lots of cpu to process. I guess the code which auto-scrolls the screen is taking all the cycles.

0

Please sign in to leave a comment.