IDEA editor - 50% of CPU

Hello,

whenever I start writing in editor (Java, JSP...) IDEA uses almost 50% of CPU and everything gets slow.

I know I won't receive something like "do this and everything will be fine" but 6.0.4&JDK 5 was ok, so I consider downgrading...
Can be JDK6 the problem? Or 6.0.5?

Linux
IDEA 6.0.5
JDK 6

Thank you

15 comments

Hello tomL,

whenever I start writing in editor (Java, JSP...) IDEA uses almost 50%
of CPU and everything gets slow.

I know I won't receive something like "do this and everything will be
fine" but 6.0.4&JDK 5 was ok, so I consider downgrading...

Can be JDK6 the problem? Or 6.0.5?


Could you please take a CPU snapshot, so that we could see the real problem
rather than guessing?

You can find instructions for taking CPU snapshots at http://support.jetbrains.com/kb/entry!default.jspa?categoryID=5&externalID=192&fromSearchPage=true

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Ooops, problem:

$ ./idea.sh
FATAL ERROR: JVMPI, an experimental interface, is no longer supported.
Please use the supported interface: the JVM Tool Interface (JVM TI).
For information on temporary workarounds contact: jvmpi_eol@sun.com
YourKit Java Profiler 5.5.4 cannot start: JVM does not support JVMPI_VERSION_1_1
Error occurred during initialization of VM
-Xrun library failed to init: yjpagent

I've added -Xrunyjpagent:port=10100 to IDEA_HOME/bin/idea.vmoptions.

0

Hello tomL,

$ ./idea.sh
FATAL ERROR: JVMPI, an experimental interface, is no longer supported.
Please use the supported interface: the JVM Tool Interface (JVM TI).
For information on temporary workarounds contact: jvmpi_eol@sun.com
YourKit Java Profiler 5.5.4 cannot start: JVM does not support
JVMPI_VERSION_1_1
Error occurred during initialization of VM
-Xrun library failed to init: yjpagent
I've added -Xrunyjpagent:port=10100 to IDEA_HOME/bin/idea.vmoptions.


Please use -agentlib:yjpagent instead.

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Try this instead:
-agentlib:yjpagent

Taras


0

6180_jaa_25.06.2007_14.43.43.zip

I hope it uploaded correctly (ftp://ftp.intellij.net/.uploads).

0

Do you have two screens and use X in Xinerama mode? I experienced a similar problem using that constellation, while using only one screen (that is no Xinerama) showed no performance problem at all.

0

Hello tomL,

6180_jaa_25.06.2007_14.43.43.zip

I hope it uploaded correctly (ftp://ftp.intellij.net/.uploads).


Yep, the snapshot was uploaded correctly. The snapshot shows that the performance
problems are caused by JSPX reparsing - do you also get slowdowns when you
work with plain Java files?

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Yes, two screens (laptop and external LCD). But I don't know whether xinerama is installed by default in Fedora, I didn't install it.

0

Problems appear also while editting CSS and plain Java files - the CPU usage isn't so huge, probably because these files are much smaller.
The interesting thing is, that I don't need to edit this JSP file - switching to the table with this file is enough for CPU usage to grow.

I made another snapshot where I edit different kinds of files and I switch between JSP and non-JSP files.


It's true that I use two screens but the problem remained even when I unplugged external screen from my laptop.

And JDK 5 didn't change anything.

0

Well it isn't JDK-specific because it's project-specific...

I created new project and no problem.

But problem still remains when I edit the old project. This old project was created in IDEA 6.0.4 and after machine reinstall and IDEA upgrade it makes these problems.

New Project->No problem
Reopen old project->CPU problem

0

Xinerama is default indeed.
While working in IDEA, open a console and run 'top'. In my case there was always the X.org process consuming the CPU (approx. around 40% while typing around in IDEA).

What worked for me was to disable xinerama and use the Nvidia Twinview facility (I have a nvidia graphics card), which has a much lower CPU and memory footprint.

(For the ultimate test, disable your second display (that is, by configuration and not by pulling out the cable) and switch to one-screen only. When it's fast then, you got the reason.)

Message was edited by:
Martin Pruefer

0

I'm sorry for little mystification, the problem isn't dependent on project.

_ The CPU usage grows above 50% when I'm editting a file no matter what type of file it is. But the bigger the worse._

And an interesting observation: the CPU usage grows faster when I type slowly (a..pause..a..pause..a).

I guess it has nothing to do with two screens and X (see screenshot).



Attachment(s):
shot.png
0

I will second that, I've been suffering for a long time on a 3 screen xinerama setup. Strangely intellij's performace can vary greatly from being fine to totally unusable, i've never been able to figure out why, though the choice of theme can greatly affect it.

0

But I don't have one big screen composed of two, but only a laptop screen and an LCD screen with the same content...

0

So, is it a problem of my hw,sw configuration or anything is bad with IDE?

Thank you.

0

Please sign in to leave a comment.