tomcat context.xml file not being deployed correctly. Perhaps tomcat 6 problem.

It appears that Idea no longer copies the META-INF/context.xml file into the
$CATALINA_BASE/conf/Catalina/localhost directory before starting up tomcat.
A file appears (e.g. root.xml for a root context) which has some sort of
made up context.xml file without any of the resources/parameters I have
placed into my web-app's context.xml file. This means for instance that JDBC
datasources do not work. Has anyone else seen this? I can't find an open
issue regarding this.

thanks,

erik


1 comment

It seems that this may be related to
http://www.jetbrains.net/jira/browse/IDEADEV-17555 though I don't think it
is the exact same issue. These basic tomcat problems are beginning to eat
away at my credibility as the local Idea zealot. Eclipse is starting to gain
mind share... I love the idea of support for things like maven but it sure
seems like solid tomcat support should come first.

-erik


"Erik Freed" <erikjfreed@codecision.com> wrote in message
news:f5p45e$jl1$1@is.intellij.net...

It appears that Idea no longer copies the META-INF/context.xml file into
the $CATALINA_BASE/conf/Catalina/localhost directory before starting up
tomcat. A file appears (e.g. root.xml for a root context) which has some
sort of made up context.xml file without any of the resources/parameters I
have placed into my web-app's context.xml file. This means for instance
that JDBC datasources do not work. Has anyone else seen this? I can't find
an open issue regarding this.

>

thanks,

>

erik

>



0

Please sign in to leave a comment.