vector is not initialized properly (but only sometimes, and only in Aurora)

i would submit it as a bug but i don't know how to reproduce it properly
separately from my code:
i have two methods in two different classes, one called immediately after
the other (from a 3rd, superceding class). Each of the two methods
initializes a vector (defined as public static Vector) and assigns it as
empty (i.e. Vector myVector = new Vector();)
When I tried adding elements to the vectors, it works with the first one,
yet doing same with the 2nd gives me an NPE. When I add a watch for both
vectors I can see that while the code is exactly identical in the two
methods, the first vector gets initialized just fine, but the 2nd one
remains null after initialization. I tried adding other locally defined
vectors within that second (non-working) method, yet they also remain null
no matter what.
This same code run under Ariadna 3.0.4 compiles and works just fine (both
vectors get initialized as they should). I'm on Windows XP and trying it
with build 823.
Any ideas?
-Jill


Please sign in to leave a comment.