How to turn off auto re-compile on MacosX?

I just moved from a Windows PC to a Mac PowerBook running MacOS 10.4.9 (a move I recommend to anyone and that I wish I had made sooner).

Anyway, on the Mac my Idea 6.0.4 exhibits an annoying new behavior. Every time I switch to a different application on the Mac, Intellij starts what appears to be an automatic Make of my project. How to I turn this behavior off? I drives me to distraction.

9 comments

a move I recommend to anyone and that I wish I had made sooner


But not if you still need to work on Windows and are a power user (aka make
heavy use of the keyboard).

0

Is it a web application? Maybe "Build on frame activation" is checked on the "Java EE Build Settings" of your web module.

0

I have found the keyboard support of Mac OS quite satisfactory. Better than windows in some cases even. And I really wish there was something as good as Quicksilver available for Windows. What do you think is missing?

Bas

0

Just take a plain Mac installation, disconnect your mouse and try to use it.
You will fail miserably:
- no way to open menus (on Windows/Unix Alt+underlined letter)
- by default you can't jump from GUI component to GUI component using tab
- the UI typically has no mnemonics, so you can't toggle a checkbox by, e.g.
pressing Alt+J
- try to log out without the mouse
- try to shut down without the mouse
- try to insert a @ character in your e-mail program with the key
combination you know from Windows (at least on my German keyboards this
will lead to Cmd+Q closing the application)
- find some programming relevant characters on the keyboard, e.g. {[]}|\ -
they are not just on different than "normal" locations, but they also are
not printed on the keyboard

Today I brought my Mac mini to the service because it did not boot any more
(happened some times before but self-repaired it by magic). It is approx. 22
months old and rarely used. Looks like I need to pay for a repair, because
Apple don't have faith in their products offering only 1year of warranty (at
least in Germany) or dumb it into the trash and buy a new one.

Frustrated Tom

PS: Sorry for highjacking this thread, but "geronimo4711" provoked me. ;)

0

To continue the hijacking:

Just take a plain Mac installation, disconnect your
mouse and try to use it.
You will fail miserably:
- no way to open menus (on Windows/Unix Alt+underlined letter)


I can transfer the focus to the menu with Ctrl+F2. Plus it is possible to assign a keyboard shortcut to any menu item of any application (but maybe not java applications) via System Preferences > Keyboard and Mouse.

- by default you can't jump from GUI component to GUI
component using tab


Works for me, and I do not recall enabling it. But "power users" should have no problem enabling this feature.

- the UI typically has no mnemonics, so you can't
toggle a checkbox by, e.g. pressing Alt+J


In the applications I use, most important user interface elements have a keyboard shortcut.

ry to log out without the mouse


ShiftCommandQ does that for me (and is default behavior).

- try to shut down without the mouse


That is what the Power button is for. But I never use that, I just close my notebook and it goes into sleep mode.

- try to insert a @ character in your e-mail program
with the key> combination you know from Windows (at least on my
German keyboards this
will lead to Cmd+Q closing the application)


That seems to be a problem of the German keyboard. Shift+2 does the trick for me.

ind some programming relevant characters on the
keyboard, e.g. {[]}|\ -


Again no problem, must be the German keyboard.

For me Mac OS is very usable with the keyboard:
- Terminal is way better than Windows command line
- I can customize the keyboard short cuts of any application
- Using Quicksilver I can perform all sorts of actions that on Windows require some combination of the start menu, windows explorer and/or the command line
- I generally do not use the Alt+Letter combinations to access the menu. I use keyboard short cuts, they are faster.

Naturally everybody has different requirements of their OS, but I also still use Windows and make heavy use of the keyboard, and Mac OS is working out fine for me. Sorry you are having problems.

Bas

0

On 2007-04-05 18:34:40 +0400, Tom <noname@jetbrains.com> said:

- no way to open menus (on Windows/Unix Alt+underlined letter)


Ctrl+F2 focuses menu bar, plain letter then focuses a menu. Thus
shutdown sequence is Ctrl+F2, Down, S, Enter.

The fact your Windows habits do not work does not mean Macs are not
keyboard friendly.

For instance, with QuickSilver installed by keyboard sequence to launch
IDEA would be Meta+Space, I, D, E, Enter.


0

Thanks Maxim and Bas, I was not aware of this possibilities. I've asked in a
Mac user forum the first time I've got my Mac, but got the answer "this does
not work with Mac - change yourself, because the Mac is much superiour than
Windows".

0

Norris, thanks!

That was it.

0

Please sign in to leave a comment.