Controlling the gutter size

I am hope I am using the right terminology, but I am referring to the area where line numbers are and version control colors appear.

I'd like to be able to control the size of this area. It seemed to jump  to a wider area when I recently upgraded from a past phpstorm version. This seems like it may be because of version control colors no longer overlapping with icons like the icon for overwriting a parent class's methods. Is there anyway to make the gutter more compact (without getting rid of line numbers)?

6
25 comments

Hi there,

I am hope I am using the right terminology, but I am referring to the area where line numbers are and version control colors appear.

Yes -- "gutter" is the right term here -- at least JetBrains is using it.

I'd like to be able to control the size of this area. It seemed to jump  to a wider area when I recently upgraded from a past phpstorm version.

Yes, it become a bit wider -- you are not the only one who noticed this. At the same time I cannot say how wider it became: on my setup it seems the same (or nearly the same -- nothing to complain about). Maybe you have some 3rd party (not bundled) plugin that makes it wider? Another possible point (don't remember where I have read it) -- it was made wider so it's easier to place breakpoints/bookmarks with mouse (before it was more problematic under in some so rare cases).

Unfortunately there is no special settings for this ( I know none).

https://youtrack.jetbrains.com/issue/IDEA-148002 -- I found only this ticket.

0

Thanks Andriy.

I guess I will put my vote in for this to be controllable!

0

Speaking of gutters, it used to be that when project and code windows were open, if you closed the project window a gutter would remain open... clicking the gutter re-opened the project window.

Where or why that went I know not, but now I have to press command+1

I am so tired of having to upgrade, then finding a different interface. How does anyone get anything done?

Grr

 

1

I guess you are talking about "View | Tool Buttons" (make sure it's enabled).

If my guess is right .. then as far as I remember in one of the versions it became disabled my default (more minimalistic UI interface -- modern trend these days, especially when users bringing "omg you have so much stuff on the screen. it's so old-days and distracts me from writing my code... that XX editor/IDE has only an editor window and it makes it so cool..." arguments when you announcing new builds in blog).

0

Whatever the cause of this problem, it is a problem that should be addressed and resolved.  Screen real estate is at a premium when developing, and this significant waste of space is more than annoying.  It is an impediment to development.

1

With tens of productivity videos of Intellij and Jet Brains in general pointing to using all sort of things to minimize irrelevant screen real estate interferes, it is indeed shocking a humongous gutter is there without customization reach. When you disable icons you cannot see toggle points and so on, so overloading icons of gutter and discarding its effect on more than 99% people that will not use much of those icons is in short anti-analytics. 

1

Found this problem goes back to 2016! I'm proposing making the gutter draggable so one can resize to one's liking.  

0

I agree this gutter is rigodamndiculous. Please make it go away or tell us how!

0

@Stephen Skrocki

Please describe your issue in details:

  • a screenshot or two (full IDE please) that would illustrate what you have there and what may be causing it -- maybe it's one of the View modes .. or too many icons in gutter area etc.
  • IDE version used
1

Attaching two images

1.  Normal view on a wide screen

2.  Zooming into text eliminates or reduces the gutter size, but now we're just swapping one problem for another

0

@Edgar Castillo

Can you please show the WHOLE IDE window (you can blur/redact private stuff if needed).

I'm just trying to understand -- are you in a Distraction Free or like mode? Check "Menu | View | Appearance" - what "Exit xxx" are there?

The thing is: the code is intentionally centered in such mode(s). And the smaller the screen is (e.g. font is larger) then it moves more to the left -- just as on your screenshot.

 

Anyway: from 2021.2 version you can now change that (implemented by IDEA-145837):

Settings/Preferences | Advanced Settings --> Left margin in distraction free mode.

5

Hi Andriy, I'm in distraction mode and setting the margin to 0 did the trick. Thanks for that! 

I would still prefer just moving it with my mouse, but this does help.

2

I would still prefer just moving it with my mouse

Rather unlikely to have this implemented just for one mode (and disabled in "normal" editing). That's my IMO only .. but seeing for how long the original issue was not addressed I'm pretty confident in my "estimate" here.

1

> I would still prefer just moving it with my mouse, but this does help.

There's no such request on our tracker - you might want to submit one at https://youtrack.jetbrains.com/newIssue 

0

Andriy Bazanov I fixed mine by switching themes.  I don't have a screenshot to share, because it is normalized now.  Themes have been another big issue for me, but that's for a different thread.  Every time there's an upgrade, I lose all of my colors, and even connections sometimes.  For some reason, the saving, exporting, importing of the themes never seem to put it back exactly how it was and I spend hours trying to fix it.  I'm sure I'm doing something wrong, so I haven't made an issue of it.  

Genuine thanks for your quick reaction to this issue though!  I followed the correct fix which you gave to Edgar Castillo and saved it in my PHPStorm notes in my YouTrack knowledge base for future reference.

0

@Stephen Skrocki

Every time there's an upgrade, I lose all of my colors, and even connections sometimes. For some reason, the saving, exporting, importing of the themes never seem to put it back exactly how it was and I spend hours trying to fix it. I'm sure I'm doing something wrong, so I haven't made an issue of it.

Better post a new thread with details:

  1. OS used
  2. How do you upgrade (a patch or remove/uninstall and make install from a full installer)
  3. How did you install the IDE (installer/ZIP or Toolbox App)
  4. Do you use one of the "sync settings to internet" plugins (IDE Settings Sync and/or Settings Repository)?

I'm on Windows; installing using full standalone installer (not a patch & not Toolbox app), not using those sync plugins. I've been upgrading like that since v0.6 or so (before the v1 was actually released) .. and do not remember any "my settings are lost" issues. Sure, small things may change (mainly because of the changes in the IDE like new code style settings etc; or a bug) .. but nothing that matches your description.

1

I'm on Windows and usually just click the Update option when the bubble pops up and says one is available.  I'm not sure, but it sounds like that is a patch?  I don't consciously or intentionally download a large file and install it as a standalone. I'll pay more attention next time. 

I'm also saving settings to the settings.zip and the repository I set up now, so will hopefully be able to restore my settings more completely.  I was never able to save settings to the JetBrains website, it was always disabled and I never figured out how to enable it.  Now I don't even see it as an option anymore.

0

I'm not sure, but it sounds like that is a patch?

Yes.

I'm also saving settings to the settings.zip and the repository I set up now, so will hopefully be able to restore my settings more completely.

I do nothing with the settings before the upgrade: updating the IDE just works and does not break them.

But if you need, just backup them manually: https://www.jetbrains.com/help/phpstorm/tuning-the-ide.html#config-directory

I just back up the whole C:\Users\USERNAME\AppData\Roaming\JetBrains folder on a daily basis (you can choose specific version if you have many/other IDEs as well and need them to be separate)

I was never able to save settings to the JetBrains website, it was always disabled and I never figured out how to enable it. Now I don't even see it as an option anymore.

Not using any of those so cannot advice here.

0

Thanks for your help.  I'll start backing up that settings folder, and I'll let you know how the next upgrade goes.

0

Andriy Bazanov 

Thank you Andriy! The latest version of Material Theme UI plugin may have an issue with 2024.1. Made my gutter so wide that takes up half of the screen. Your solution fixed it perfectly!

0

If you're running 2024.1 with Material UI this fixed it for me
Settings → Appearance & Behavior → Material Theme UI → Features → Uncheck “Centered Editor” and hit apply

Before

After

4

Thanks Ahall ! I thought it was a bug.

0

Thanks Ahall! I thought it was a bug too. This should be off by default.

0

Thanks! Thought I was going to have to spend all morning pulling my hair out trying to solve this. Yes, should be off by default.

0

Please sign in to leave a comment.