PhpStorm 10 - sluggish - OSX 10.10.5 i7, 16 GB RAM

I'm using PhpStorm 10 now with the bundled JVM on my custom Mac (as wells as on an iMac at work) which is a beast of a machine (i7, 16 GB RAM) and PhpStorm is still sluggish as hell.

Resizing the application window is slow. Scrolling in an editor window is slow. Typing to the terminal is slow.

I don't get why the performance is so bad compared to PhpStorm on Windows. I have tuned the vmoptions to be able to use 2048m of memory. But it is still not better. I hope that someone can help me.

Bildschirmfoto 2015-11-06 um 10.33.47.png

Filesystem Info:
File system is case sensitive: false
Are there symlinks: false
Number of files: 1182

System Info:
Number of CPU: 8
Used memory: 328Mb
Free memory: 216Mb
Total memory: 545Mb
Maximum available memory: 1981Mb

Project Info:
Number of opened files: 1
File size (in lines): 162
File size in characters: 6375
Last action: _Undo
Number of injection: 0

IDE Info:
Custom plugins: [TypoScript Plugin (1.6), EditorConfig (142.1464), BashSupport (1.5.1.143), NodeJS (143.381.11), Laravel Plugin (0.8), Symfony2 Plugin (0.11.100)]
Disabled plugins:[]
Build version: PhpStorm 10.0 Build #PS-143.381 October 31, 2015
Java version: 1.8.0_40-release-b92x86_64
Operating System: Mac OS X (10.10.5, x86_64)
JVM version: OpenJDK 64-Bit Server VM JetBrains s.r.o



Attachment(s):
PS-143.381_denis_06.11.2015_10.40.21.zip
PS-143.381_denis_06.11.2015_10.38.35.zip
PS-143.381_denis_06.11.2015_10.37.09.zip
11 comments
Comment actions Permalink

Does no one have this problem on OSX?

0
Comment actions Permalink

Yes I'm having the same issue real pain.

My specs are about the same and phpstorm is just so slow and then crashes totally unusable.

0
Comment actions Permalink

My iMac is not as powerful as yours, but I noticed quite a drop in performance from 9 to 10.  So much so that I just reverted to 9 again as it was too laggy.  Hopefully an update comes that makes it happier.

0
Comment actions Permalink

I confirm I have the same issues with overall IDE performance.

I'm using Linux. PhpStorm 9 works just excellent.

0
Comment actions Permalink

I'm on OSX 10.11.1 'El Capitan' and the performance is really bad. I also have an i7 16gb machine. I get the 'color wheel' constantly and I'm finding it really hard to actually use, as the buffer hangs whilst I'm typing.  

0
Comment actions Permalink

Yes, it is definitely quite slow.  Not to mention the constant reindexing.

0
Comment actions Permalink

I'm having the exactly same problem on El Capitan with a Powerbook and 16GB Ram. the fan cooler often turns like crazy and the CPU usage goes up to 800%. I just don't understand why this problem will not be analyzed/corrected by Jetbrains. Once I disabled so many plugins that is just 1 level over a standard text editor. It took a while longer but then the performance problem came back. 

I love working with the IDE but I am heavily disapointed by these persisting performance issues. I am already looking for another editor supporting HTML, Javascript and PHP and I'm not up to tweaking, fiddling and what ever playing around with the PHP Storm settings to solve Jetbrains problems. If you can tell me some alternatives I'm glad to hear (doesn't matter if for free or if it costs something).

0
Comment actions Permalink

Hi Tayger.  I would recommend you pull down phpStorm9.  I think storm is an awesome piece of software and version 9 works great.  I will switch to 10 once these performance issues are addressed, but I have no qualms about version 9.

1
Comment actions Permalink

Thank you David, that was the best tip you could give me! I still can use this nice IDE and don't have this lack of performance. Well it still goes up to 200% of CPU but way better than 800%. Thanks a lot!

0
Comment actions Permalink

Possible Solution? 

I was having massive lag while typing on a very high spec MBPro

There seems to be a problem if you mark a directory as excluded (right click "mark as" rather than excluded in deployment).

 


 

I had our /vendor directory marked as excluded as it was massive, removing the exclusion meant it reindexed once and suddenly everything is back OK.

Might be useful to someone, see if it works.

0
Comment actions Permalink

Thank you too... I didn't change anything else than just deactiviating many plugins. So your case didn't happen to me but good to know.

 

0

Please sign in to leave a comment.