How to disable javascript auto completion on PhpStorm

Everytime I start to edit javascript, PhpStorm starts auto completion. Then it almost always showed a dialog box saying you need to increase XMS memory, so I increased it to 4GB.
It does not complain as much as before, but now my hard disk swaps a lot and whole my system freezes for a minutes or so. It happenes everytime I change javascript. I cannot stand it.
I cannot increase the physical memory. So, I would like to disable auto completion for ONLY javascript. Is there a way to do that?

4 comments
Comment actions Permalink

No:( You can enable 'power save' mode (File/Power Save Mode), but it will affect all files, not just javascript. Or, you can treat your .js files as simple text - by assigning '*.js' pattern to 'Text files' file type in Settings | Editor | File types

0
Comment actions Permalink

That is a bad news... often javascript is written in .php template file and I want auto complete for php. So, I do not want to disable it for .php file. It means I cannot set 'Text files' for .php.
I wonder why not many people are complaining about this issue. This is so pain.

0
Comment actions Permalink

Nobody is complaining because javascript completion normally works fine. I'd suggest creating a support ticket to track down your issue.
BTW, you can disable auto-completion for all files and invoke completion explicitly via Ctrl+space once you need it

0
Comment actions Permalink

OK. I will try the Ctrl+space way and I will contact the support if it gives me too much trouble.
Thanks for your reply!

0

Please sign in to leave a comment.