My Terminal tab has weird background color. Any ideas how to fix this?

Hi, I have googled and searched for an answer in the KB and these forums but I haven't found anything similar.

My problem is purely aesthetic but I would like to fix it anyways.
Tha thing is that in PhpStorm the Terminal tab uses the theme colors but the background starts with a different bright color. I have tried changing the terminal colors from settings and looked at the settings in my cmd and powershell configrations also to no avail.
This only happens in this tab.

Any ideas?

Here is a screenshot
bg.png

10 comments
Comment actions Permalink

I had the same issue and Elena's answer helped me figure it out!

I changed the default cmd colours by right clicking on the title bar of the command prompt window > Defaults and then from the "Colors" tab changed Screen Text to white and Screen Background to black. After restarting IDEA the terminal colors look normal and the annoing background is gone.

4
Comment actions Permalink

Seems you have some custom colors set for screen text and background in Windows cmd console properties. See

https://youtrack.jetbrains.com/issue/IDEA-145236, https://youtrack.jetbrains.com/issue/IDEA-124182.  The solution is to set cmd console colors back to defaults - by either  editing the registry key or by modifying default cmd console properties
3
Comment actions Permalink

Have you tried File | Invalidat caches and restart?

0
Comment actions Permalink

Hello!

what IDE theme and editor color scheme are used? What shell is chosed in Terminal settings?

0
Comment actions Permalink

Thanks, I hadn't tried this, but it still didn't work.

0
Comment actions Permalink

Hi, thanks for your reply.

I'm using the 'Darcula' IDE Theme and 'Monokai' as editor scheme.
In the Terminal settings, my shell path is cmd.exe (I am running PHPStorm on Windows).

0
Comment actions Permalink

Can you maybe switch to the Alloy IDEA theme, then restart. If issue is gone, switch theme back to Darcula and check if the behavior is normal again.

0
Comment actions Permalink

This is still a problem in other JetBrains products, such as WebStorm 11.0.3 on Windows 10 64-bit as the attached screen shot clearly shows.

Nothing I do, such as changing themes back-and-forth or resetting to defaults does any good.



Attachment(s):
WebStorm Terminal Window Color Problem.JPG
0
Comment actions Permalink

This isn't fixing the problem for me. I've deleted ScreenColors from my HKEY_CURRENT_USER\Console and nothing changed...

0
Comment actions Permalink

Thank you Elena for your comment.  Changing my windows 10 console colour back to default white text and black background resolved my awkward text background being displayed in the IntelliJ console.

0

Please sign in to leave a comment.