Builtin server of PHPStorm 10.0.2 not properly working on OSX El Capitan

I had some major change in my current project while I was offered to upgrade to latest PHPStorm version (10.0.2). Installed it, all fine so far. I have to say I'm quite new to JetBrains tool like PHPStorm. After a while I realized some Ajax calls dont work properly. After some investigations (hours later) I realized that Ajax calls passing parameters to a PHP script (POST) cant be read hout by $_POST[...].  They are just empty!!!! After further investigations I realized that my installed MAMP version is not used (Safari unfortunately hided the Server port), instead of it some "Builtin Server" was used!!!! WT..... I found the following link to configure another server (documentation is a bit outdated, but the steps are obvious): https://confluence.jetbrains.com/display/PhpStorm/Installing+and+Configuring+MAMP+with+PhpStorm+IDE That way I "switched" to my MAMP Apache Server, PHP and MySQL.

After restarting PHPStorm the Builtin Server is still used! By hazard I found some further settings in the upper right corner of the editor ("Select Run/Debug Configuration") in which I found a further URL using the Buildin Server address (63442) that I changed to my MAMP Port (80). The URL is confusingly located directly to one of my files in my project. Well then this has to be that way. After this correction I expected it would work now but only when pressing the green play button next to the pulldown menu is using MAMP at Port 80. When clicking on a browser symbol inside the editor window (they appear in the upper right corner) still uses the Builtin Server at Port 63442.
I feel dominated by this Builtin Server and don't know how to override it for any cases (run, debug, ...). After the explained problem I don't trust to it. I found the Builtin Server Port in some other places but was unable to set it to 80 (jumped back to 63442).

Is there ANY way to completly override the Builtin Server?

Desperate greetings

3 comments
Comment actions Permalink

Hi there,

I found the Builtin Server Port in some other places but was unable to set it to 80 (jumped back to 63442).

You should not change that option. At least it will not help in resolving this issue.

Is there ANY way to completly override the Builtin Server?

Just define Deployment entry (in-place type should be enough), provide correct URL there (that will be served by your MAMP) and mark this deployment as default for this project (do not forget this step).

Now IDE will use that URL in "Open in Browser" and other actions (this means: IDE uses built-in server if no proper server is defined).

Obviously, if you have URLs with built-in server anywhere else (e.g. other Run/Debug configurations; PHP Debug server entries etc) then you will have to adjust them as well.

0
Comment actions Permalink

Thank you! In between I just did what you said and the Default Setting on Deployment is really important. Nevertheless. the $_POST problem on PHP side resists but now I can work with MAMP where the problem doesn't exists.

0
Comment actions Permalink

Me too, $_POST missing for ajax requests for windows built in server using php 5.6.15.  10.0.1 still working fine so will revert to that until fixed.

0

Please sign in to leave a comment.