How to change the background color of the "Run" tab of "Gulp"?

How to change the background color of the "Run" tab of "Gulp", as visible on the screenshot?
Currently it is light gray, and the normal text is also light gray, so it's not visible. I selected two lines and they became visible, because the selection background is dark blue.
scr.JPG

6 comments
Comment actions Permalink

Hmm... usually it's configured in Settings | Editor | Colors & Fonts | Console Colors...

0
Comment actions Permalink

The Console Colors are fine and in the normal Terminal window (or Console), which opens after clicking on the Terminal tab at the bottom the background is black and letters are gray. The problem occurrs only if I double click on the Gulp task (in the Gulp panel). Then the "Run" tab (visible on the screeenshot) opens automatically and shows Gulp log and it has light gray background and letters.

I also changed the Console colors settings to two default schemes. In Blackboard scheme the problem persisted identically. In Default color scheme on the other hand, the Gulp log background became black and letters also became black.

scr1.jpg

And by the way, opening the regular Terminal and typing "gulp" works fine, no colors, just output. So maybe I'll work that way, although I think the Gulp panel is there for a reason (easier clicking than typing), and also colorful output is more readible than monocolor (should be more readible, currently it's unreadable).

0
Comment actions Permalink

If you have 3rd party plugins installed, please try to disable them one by one, in theory they could interfere with the background color.

It could be a bug in "Console Colors". Could you please share your screenshot of "File | Settings | Editor | Colors & Fonts | Console Colors"?
Please attach your idea.log (on the main menu "Help | Show Log in ..."), it might light some shed.

Is the problem with background console color reproducible for some other console (not Terminal)? For instance, please create .php file with content:

 
<?php
    echo "Hello World";
    echo "\n";
?>


and run it using "PHP Script" run configuration (on the main menu "Run | Edit Configurations...", add "PHP Script" run configuration)
Will there be the same problem? Thanks.

0
Comment actions Permalink

Running the "Hello" php code in PHP script mode opens a "Run" console with white letters on black background.

I think I have no 3rd party plugins, this is a fresh trial install of PhpStorm 10 (I imported settings from my PhpStorm 7).

Here is the screenshot of console colors settings:

scr-colors.JPG
I ran the Gulp and attached the idea log.



Attachment(s):
idea.log.zip
0
Comment actions Permalink

Thanks for the details.
Well, "Gulp" console default background color was expected to be the same as in "PHP Script" console. It's a bug in Gulp console, I guess.
Is the issue reproducible with other Gulp projects?
For instance, please try to run gulp serve for a sample project generated by https://github.com/yeoman/generator-gulp-webapp:

npm install --global yo gulp bower
npm install --global generator-gulp-webapp
yo gulp-webapp

Then open the generated project in PhpStorm, add gulpfile.babel.js as Gulpfile and execute serve task.
Will there be correct background color?

0
Comment actions Permalink

Probably related issue in PhpStorm's console: https://youtrack.jetbrains.com/issue/IDEA-149450. Fix will be included in PhpStorm 10.0.3 (ETA: 2016, January).

0

Please sign in to leave a comment.