PhpStorm auto-formatter

Why the hell is phpstorm doing this to my code every time i change something in a code line ?

Capture d’écran 2015-12-14 à 10.20.35.png

How to disable this please ?

3 comments
Comment actions Permalink

Hi there,

I think it must be your wrapping settings (Settings/Preferences | Editor | Code Style | PHP).

Wrapping occurs when your line length hits the right margin limit.

You either need to

  • up you right margin (can be set globally or for PHP files only -- although I cannot say what margin will be used in HTML/PHP mix -- HTML or PHP one)
  • or change settings to not to perform such wrapping


Unfortunately I cannot say what code style setting in particular is responsible for this .. but it should be one at the "Wrapping & Braces" tab -- either array or function call parameters related)

Also check if "Wrap on typing" option is enabled (Hint: Settings/Preferences screen has search box -- use it to quickly find specific settings control)

0
Comment actions Permalink

Thanks a lot Andry, you saved me :x

0

Please sign in to leave a comment.