help upgrading Webstorm in ubuntu 15.10

i need help installing webstorm upgrade.

i installed webstorm-11.0.1 through the ./webstorm.sh file.
this created a icon in the appllications folder that runs the app.
it aso created /.webstorm11 folder with configuration files in the home folder.

i tried to install webstorm-11.0.2 same way by running the ./webstorm.sh file.
since i thought it only creates a launcher icon in the applications menu, that runs the app from it's directory,
i thought it will override my current launcher icon and install the new one but it doesn't.
and i get some warnings in the terminal also which i don't understand. ( in the photo below)

the actual question - how do i install the new version of webstorm on ubuntu if i currently have a lesser version installed???



Attachment(s):
Screenshot from 2015-12-12 12-35-07.png
1 comment
Comment actions Permalink
i tried to install webstorm-11.0.2 same way by running the ./webstorm.sh file

webstorm.sh file runs the application, it's not the installer. To install WebStorm, you just need to extract the downloaded archive to preferred empty (!) directory


i thought it will override my current launcher icon and install the new one but it doesn't.


Please delete or rename the previous WebStorm entry and then create a new one for WebStorm 11.0.2 from Tools| Create desktop entry.

i get some warnings in the terminal also which i don't understand.


messages are caused by missing log4.xml and log4.properties. https://youtrack.jetbrains.com/issue/IDEA-148979 is fixed in next major release branch; meanwhile  I can suggest ignoring these messages - they don't indicate any actual problems and don't make any harm

0

Please sign in to leave a comment.