"V8CommandProcessor$1" debugging error with NodeJS

If I run the tipical NodeJS server app, i can debug just fine, but if I try to run a single .js as a standalone script I get weird errors. For example:

var request = require('request');
request = request.defaults({
   jar: true              // Cookies ON
var cheerio = require('cheerio');


It's just a snippet from a js app that makes requests. If I run it, webstorm outputs "testing..." without any errors. If I try to debug it though, i get the same error sprinkled everywhere and I can't debug it.
Sometimes I can't retrieve variables:

If, when execution is paused with a breakpoint, I hover over keywords like "express" (a require) or require itself, I get the same:


The 8th line is the last one from the code I pasted: console.log('testing...');
And udemy.js:1:63, line 1 position 63? If I understood correctly, as you can see that position doesn't exist.


Yes, Node 5.0.0

Indeed it seem similar. Webstorm bug? What do I do?



Please sign in to leave a comment.