Debug session was finished without being paused

PhpStorm 10.0.1 and xdebug. I run PhpStorm on a Mac, the project is on an NFS share, the NFS server  runs inside a local VMware Fusion box. Typical vagrant environment.

I get notified very often:

> Debug session was finished without being paused
> It may be caused by path mappings misconfiguration or not synchronized local and remote projects.
> To figure out the problem check path mappings configuration for 'awg.site 80' server at PHP|Servers or enable Break at first line in PHP scripts option (from Run menu).

I have no problem. Debugging works fine. However, I don't dare to click on „never show again“ until I have understood what might be the problem. I mean, “Debug session was finished without being paused“ doesn't even sound like a problem. Why should it pause? What's bad in that?

Google shows only the same question like mine in russian languaghe without an answer.

Thanks,
Jörg

4 comments
Comment actions Permalink

You are right it's fine to have debug session without any breakpoints reached, e.g. it's common if you have Ajax request.
The warning is intend to help new users to configure debugger. If "Break at first line" option is disabled and there's some error that silently prevent you to setup breakpoints (e.g. there's a typo in path mappings at PHP|Servers, remote and local file versions are not synchronized, etc) then nothing will happen on page reload. This situation is indistinguishable from xdebug misconfiguration (e.g. wrong "xdebug.remote_host", "xdebug.remote_port") therefore you may spend a lot of time to figure out the problem. The message is saying that debugger itself is configured correctly and suggest you next step in troubleshooting process.

If you have no problem and debug session without breakpoints is expected behavior then just disable it.

0
Comment actions Permalink

@Svetlana

Problem is (at least in 10.0.2 EAP build 143.1044) that this message also show after actual successful debug session.

This is how I can reproduce it right now:

1. I'm debugging local web project (zero config approach -- via "phone handle" icon + browser xdebug extension)
2. After breakpoint was successfully hit .. I step over/in few more lines (did not checked much .. but have the same unwanted result with at least one step over)
3. Now I just click on "Resume Program" button in Debugger window -- page gets executed till the end .. but that message is now shown (why?)

PHP 5.6.15 x86 NTS; xdebug 2.3.3; IIS 7.5 as web server (PHP via FastCGI, if this makes any difference)

---

BTW -- if I would accidentally run (debug) session with no breakpoints set at all (e.g. forgot to disable cookie in browser) .. that message will be shown twice...

0
Comment actions Permalink

Would you please provide xdebug log file? It looks like you have two debug sessions for each request (that's why it is shown twice for session with no breakpoints). Please, try to reproduce issue on simple project.

0
Comment actions Permalink

Thanks for suggestion.

You were right -- it was request for missing favicon.ico that was generating this 2nd session.

0

Please sign in to leave a comment.