xdebug is no more working on PHPStorm 10

hi

yesterday I upgraded from version 9 to 10, and now xdebug is not working anymore on a custoner's remote server...

with "remote configuration" as it was in phpstorm 9, debugging was just ignored, no breakpoint hit with cookies set.. so I tried with zero configuration and now I get

"remote host is configured as 'localhost' despite server host is probably not local" on validation

until yesterday, with phpStorm 9 all worked fine

3 comments
Comment actions Permalink

from the xdebug docs,

xdebug.remote_host:
"[...] This setting is ignored if xdebug.remote_connect_back is enabled."

xdebug.remote_connect_back *IS* enabled on the server, so could this be a BUG of version 10?

0
Comment actions Permalink

Hi there,

Validation is just for information purposes (for you) and may indeed not cover all cases (like the one you have mentioned).

1) Please show your xdebug section of phpinfo(); output captured in a same way as intended debugging (e.g. if you want to debug a web page then capture it via browser).

2) Please provide xdebug logs for such unsuccessful debug session -- http://xdebug.org/docs/all_settings#remote_log

3) Your debug process (how you initiate debug in PhpStorm).

0
Comment actions Permalink

thanks!

seems to be solved...

some firewall issues/differences with phpstorm9 and phpstorm10 on some internal business networks

0

Please sign in to leave a comment.