Dart new project sample content is missing

Hi Community!

We use WebStorm 10.0.4 for dart development. Since yesterday the "Generate sample content" list has changed. Now I try to find information where this data is stored. It is not part of the dart-sdk, as I have now rolled back to version 1.10.1, the webstorm 10 version on my private pc at home (licened of course), which still shows the full list of sample content.

What the "Generate sample content" list shows now:
Dart Web App
Dart Command Line App


Before 8 entries were shown, including "Polymer Web Application"
http://www.directupload.net/file/d/4070/4pe83342_png


My questions are:

  • Where is the data for the sample content stored?
  • Can I bring the sample content back by copient a file or edit some file?
  • Why has it changed suddenly?



(Unfortunately I'm not able to add screenshots to this post. Firefox will not show the "Insert Image" dialog form, IE give a HierarchyRequestError.)


Maybe someone can help?

Stephan

3 comments
Comment actions Permalink

project templates are taken from stagehand Dart package (https://pub.dartlang.org/packages/stagehand)


that is downloaded when you choose 'Dart' project in New project wizard. Seems that downloading has failed for some reason (networks issues? server failure?). Can yhou check if the problem persist after WebStorm restart?

0
Comment actions Permalink

Hi Elena,

thank you for the info. I restarted WebStorm and the pc/Windows several times with no effect.

I solved this by using pub's Repair Cache. This redownloaded all packages to the C:\Users\<username>\AppData\Roaming\Pub\Cache\hosted\pub.dartlang.org folder.

Now it works again!

0
Comment actions Permalink

Thanks. This worked for me too. Same problem, and spent quite a while head-scratching.

0

Please sign in to leave a comment.