Re: why don't you use JDOM Beta 9???

Apologies for resurrecting an old thread, but JDOM beta 9 has been available for quite a while now and fixes the memory leak StringBuffer issue that was introduced with j2se 1.4.1 - I tried updating my own installation, but unfortunately there have been some API changes since the aged beta 7 IDEA currently uses, I get:

java.lang.NoSuchMethodError: org.jdom.Text.getValue()Ljava/lang/String;
at com.intellij.util.JDOMUtil.replaceText(JDOMUtil.java:56)

from beta 9; I'm only asking for the sake of plugin developers who are having to regress their existing JDOM code just to fit in.

Any chance of getting up updated in a future version of IDEA? And for IDEA 3.0.x?

- Richard

Please sign in to leave a comment.