why 816 cannot resolve jsp taglib at all?

the same project, all same settings
in 3.0.4 it's ok.
but in 816, all taglib tag is red.
:( anybody else met that?

6 comments
Comment actions Permalink

It's a known issue with 815 and 816. They can resolve taglibs but only if the taglibs have a 1.2 DTD which your taglibs apperantly hasn't.

The official response when that was discovered was:

"We'll try to support 1.1 format ASAP. I hope this issue will be resolved in next 3-4 builds."

0
Comment actions Permalink

thanks.
It's very sad to hear that. It has been a long time since I didn't watch the tracker.

0
Comment actions Permalink

Actually Daniel, I changed my DTD to 1.2 and it made no diff.

R

"Daniel Bratell" <jiveadmin@jetbrains.com> wrote in message
news:20620138.1054097905279.JavaMail.jrun@is.intellij.net...

It's a known issue with 815 and 816. They can resolve taglibs but only if

the taglibs have a 1.2 DTD which your taglibs apperantly hasn't.
>

The official response when that was discovered was:

>

"We'll try to support 1.1 format ASAP. I hope this issue will be resolved

in next 3-4 builds."


0
Comment actions Permalink

Well, did you just change the DTD or have you updated the taglib descriptor to use the 1.2 syntax?

Quite a difference. IDEA needs to correctly parse the taglib descriptor, and currently it only supports the 1.2 syntax. Make sure the descriptor is well-formed and can be correctly parsed.

0
Comment actions Permalink

I did both just to make sure. I would think that the tag lib reference
pointing to the 1.2 dtd should be enough no? The descriptor is righ off the
official site, for the JSTL tags, so I have no control over that.

R
"Marcus Brito" <pazu@animegaiden.com.br> wrote in message
news:20016773.1054124703576.JavaMail.jrun@is.intellij.net...

Well, did you just change the DTD or have you updated the taglib

descriptor to use the 1.2 syntax?
>

Quite a difference. IDEA needs to correctly parse the taglib descriptor,

and currently it only supports the 1.2 syntax. Make sure the descriptor is
well-formed and can be correctly parsed.


0
Comment actions Permalink

I have some strange behaviour:
My taglibs are recognized correctly by IDEA, but then running Tomcat it can't load my custom tag classes. Using the same classes and the same TLDs with IDEA 3.0.4 works.

0

Please sign in to leave a comment.