ANT build scripts suddenly using javac2

Hello,

I recently regenerated my ANT build scripts from IDEA and for some reason all the previously generated tasks were generated as tasks. I'm not sure what I might have done to cause this. The only recent changes to the project were the addition of a few libraries. Can someone enlighten me on the difference between and and what might have caused this change? From what I understand I need to manually edit the build scripts to get ]]> to work. I'd rather avoid that if possible.

Thanks,
Ray

3 comments

Hello Ray,

I recently regenerated my ANT build scripts from IDEA and for some
reason all the previously generated <javac> tasks were generated as
<javac2> tasks. I'm not sure what I might have done to cause this.
The only recent changes to the project were the addition of a few
libraries. Can someone enlighten me on the difference between <javac>
and <javac2> and what might have caused this change?

From what I understand I need to manually edit the build scripts to
get <javac2> to work. I'd rather avoid that if possible.


The ]]> task additionally performs @NotNull instrumentation and UI Designer
form compilation. You shouldn't need to edit build scripts to make the task
work.

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Hello Ray,


The <javac2> task additionally performs @NotNull
instrumentation and UI Designer
form compilation.


I'm not using either of these; is there a way to use the old ]]> task?

You shouldn't need to edit build
scripts to make the task
work.

I take it you mean I can add the jars to the ANT installation?

Thanks,
Ray

0

>

I'm not using either of these; is there a way to use the old <javac> task?

>
before generation there is a dialog popping up, where you can uncheck "Enable UI form compilation". The script will be generated in
terms of "javac" task.

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0

Please sign in to leave a comment.