Default charset not working in Ubuntu.

Hello, I am a Ubuntu (Feisty Fawn) user and I am trying IDEA to use in the company that I am working for.

But I have a little problem: in every editor in Ubuntu I can write chars like 'é', 'ã', 'õ' and others used frenquently in portuguese language. But in IDEA I don't. I already have configured the "Default Encoding" option for "System default", "UTF-8", "ISO-8859-2" but none of this works and I still getting text like this (pay attention for ? chars):


If I execute "locale" command from a terminal window, I get the following result:

LANG=pt_BR.UTF-8
LANGUAGE=pt_BR.UTF-8:pt.UTF-8:pt_PT.UTF-8
LC_CTYPE="pt_BR.UTF-8"
LC_NUMERIC="pt_BR.UTF-8"
LC_TIME="pt_BR.UTF-8"
LC_COLLATE="pt_BR.UTF-8"
LC_MONETARY="pt_BR.UTF-8"
LC_MESSAGES="pt_BR.UTF-8"
LC_PAPER="pt_BR.UTF-8"
LC_NAME="pt_BR.UTF-8"
LC_ADDRESS="pt_BR.UTF-8"
LC_TELEPHONE="pt_BR.UTF-8"
LC_MEASUREMENT="pt_BR.UTF-8"
LC_IDENTIFICATION="pt_BR.UTF-8"
LC_ALL=

How can I solve this problem?

Kind Regards

4 comments

Do you mean you got these squares instead of actual characters displayed in
the IDEA editor?
What encoding your files in?

--
regards,
--
Alexey Kudravtsev
Software Developer
JetBrains, Inc, http://www.jetbrains.com
"Develop with pleasure!"

"Marcos Silva Pereira" <marcos.silva@gmail.com> wrote in message
news:3401627.1179898075745.JavaMail.itn@is.intellij.net...

Hello, I am a Ubuntu (Feisty Fawn) user and I am trying IDEA to use in the
company that I am working for.

>

But I have a little problem: in every editor in Ubuntu I can write chars
like 'e', 'a', 'o' and others used frenquently in portuguese language. But
in IDEA I don't. I already have configured the "Default Encoding" option
for "System default", "UTF-8", "ISO-8859-2" but none of this works and I
still getting text like this (pay attention for ? chars):

> * Retorna true se o somente se a quantidade de tempo disponivel para o
> * atendimento ? menor do que o tempo gasto, considerando suspens?es
> * que devem ser contadas.
> ]]>

>

If I execute "locale" command from a terminal window, I get the following
result:

>

LANG=pt_BR.UTF-8
LANGUAGE=pt_BR.UTF-8:pt.UTF-8:pt_PT.UTF-8
LC_CTYPE="pt_BR.UTF-8"
LC_NUMERIC="pt_BR.UTF-8"
LC_TIME="pt_BR.UTF-8"
LC_COLLATE="pt_BR.UTF-8"
LC_MONETARY="pt_BR.UTF-8"
LC_MESSAGES="pt_BR.UTF-8"
LC_PAPER="pt_BR.UTF-8"
LC_NAME="pt_BR.UTF-8"
LC_ADDRESS="pt_BR.UTF-8"
LC_TELEPHONE="pt_BR.UTF-8"
LC_MEASUREMENT="pt_BR.UTF-8"
LC_IDENTIFICATION="pt_BR.UTF-8"
LC_ALL=



0

Yes, I get these squares instead correct characters. Because I have created the java files in IDEA itself, I think that their encondings is the same of configured for IDEA. To me, seems that IDEA does not support default enconding (that comes from Ubuntu).

Kind Regards

0

Ok, then could you please create the jira issue and attach the files under
the question there?

--
regards,
--
Alexey Kudravtsev
Software Developer
JetBrains, Inc, http://www.jetbrains.com
"Develop with pleasure!"

"Marcos Silva Pereira" <marcos.silva@gmail.com> wrote in message
news:30011800.1179927067826.JavaMail.itn@is.intellij.net...

Yes, I get these squares instead correct characters. Because I have
created the java files in IDEA itself, I think that their encondings is
the same of configured for IDEA. To me, seems that IDEA does not support
default enconding (that comes from Ubuntu).

>

Kind Regards



0

Alexey, I have search for other bugs like this in Jira, but I could not found any. So, I have create one new:
http://www.jetbrains.net/jira/browse/IDEA-12886

If it requires more details about anything related with my system, I am pleasured to add more information.

Kind Regards

0

Please sign in to leave a comment.