VERY slow debugging with Node.js + ECMA6 + angular-fullstack generater

I'm working on a node project and I used "yo angular-fullstack" to generate it. This created a project that uses ECMA 6 syntax, so I enabled that in the project settings. Unfortunately, this seems to have slowed debugging down to a crawl. I found a reference somewhere to disabling js.debugger.v8.use.any.breakpoint and tried that and it helped some, but debugging is still intolerably slow. Any suggestions?

I'm using WS 10.0.4. OS X 10.10.5. MacBook Pro (17-inch, Late 2011). 2.5 GHz Intel Core i7. 16GB memory.

Any help would be greatly appreciated!

Also, does anybody know if angular-fullstack by default generates projects with ECMA 6 syntax? Mostly it's the import vs require statements. I'm wondering if there is a flag somewhere I can set to have it generate ECMA 5 script.

Thanks,

Andrew Hughes

1 comment
Comment actions Permalink

what node.js version do you use? Node 0.12.*  (and latest 0.11 builds) is known for slowness while debugging - https://github.com/iojs/io.js/issues/877. See https://youtrack.jetbrains.com/issue/WEB-16076#comment=27-981720 for possible workaround.

as for the generator stuff, https://github.com/DaftMonk/generator-angular-fullstack suggests that you can choose either  

JavaScript or Babel as scripts - 'JavaScript' stands for 'standard' javascript, I suppose...
0

Please sign in to leave a comment.