Debugging JBoss

Hi there,
I'm developing web-applications with IntelliJ 6.0 on Windows XP using JBoss 4 as application server. From one day to another my debugger went extremely slow. I'm debugging a remote JBoss. It takes about 3 minutes to reach a breakpoint, which previous took about a few seconds. I didn't change anything in my IDE-settings or in the server configuration. I tried a whole day to get rid of this problem, but nothing helped! I uninstalled IntelliJ and removed the folder in userhome and programs. As I re-installed it i said not to use old settings. But after starting the IDE it seemed like some of my custom settings were not lost. For example the Antbutton is by default on the right side. I use to have it on the left. After reinstalling it still was at the left side!? Are there any other hidden program- or chache-folders or registry entries which I can delete?
So please could anybody give me a hint to remove this ugly problem!? I don't want to reinstall windows because of that or even much more worse: use another IDE for debugging ! I'd like to continue my work with the best Java-IDE on this planet
Thanks & regards
Dominik

7 comments

Maybe you need extra horse power (RAM or a better CPU, maybe).

0

Hi Dominik,

From what I can see, you are having some memory/CPU usage/network traffic problem. Those things are irrelevant to your IDE settings. Maybe there is some virus/spyware that greatly affects your pc performance. So try to scan your pc or run spybot to remove it.

Br,
Carlos

0

Thanks for your replies!
I've got a P4 with 3 GHz and 2GByte RAM, so I don't think I've got a horse power prob. I tried debugging with eclipse and everythings fine. I'm checking the issue with virus and spyware. If anybody had the same problem and fortunately solved it, please let me know ;)
Dominik

0

I know you've reset your configuration, but are you using method breakpoints at all? These can really slow down the debugger.

0

Totally - in the debugger click on the 'View Breakpoints' button (Ctrl-Shift-F8) and make sure there is nothing in the method breakpoints tab

0

Gotcha! I really don't know why - but I know how I solved the problem. After one more senseless re-install-action I set up a new project and everything was ok! Something in my old projectfile(s) made anyhow the difference!?
Thanks to everybody & regards
Dominik

0

Finally I forgot to close this thread by marking it as answered ;)

0

Please sign in to leave a comment.