Undo in Selena is working differently than in 6.0

I have problem with Undo feature in Selena. It seems to me that you have changed the behaviour quite a bit. When I do undo, it will undo all lines at once! In 6.0 the undo was per line.
Not only this leads to lots of unexpected errors in my code but also i really need undo per line as was in 6.0.

Could you please implement some checkbox in options to use old behaviour?


For me it is only undoing the last line like it always has. (using 7.0 M1).


Interesting. Now I have tried it again. I have two projects open in separated windows (but same instance of idea). In first one undo behaves normally, in second one removes all lines at once. This must be some kind of bug or what...


I see a behaviour something like:
1 - multiple actions within short time only need 1 undo action invocation. (which is indeed not very handy imho)

2 - multiple actions with a bit of time in between need multiple undo actions.


Hmm, I tested that scenario as well and it still worked fine for me.

Definitely something odd...I actually have a problem with IntelliJ since 6.0.4 (including 7.0 M1) that only occurs on my work computer, no one else seems to have the issue and I myself don't have the issue on my home computer with the same version of IntelliJ (on my work computer IntelliJ will jump to the wrong line using CTRL+B on the first attempt, subsequent attempts jump to the proper line).

Maybe it is specific to your computer? Do you have another machine you could test it on?


It looks even more interesting. I did more tests. It is somehow related to VCS. Lets say you have checked out a file from VCS.

1) File is not modified. You duplicate two different lines and make undo.
The undo works per line.

2) File is not modified. You duplicate two different lines. The lines are marked green as changed. You duplicate the changed lines. Make undo. The undo will remove more lines at once.

PS: Version 7.0M1


I did not see any differences related to time between actions.


I've definitely noticed the undo being much more "greedy" in Selena that 6.0. Sometimes it's handy, but it's mostly frustrating as the cursor flies all over the shop if you edit code too quickly.


I've actually noticed it really badly tonight and it seems to be that certain actions trigger an "undo point" and others just don't trigger it at all.

Some examples which undid a bit too much for my liking:
- Copy and pasting text - I pasted a variable name more than 30 times into random parts of a Java class. Carrying out an undo undid every single one of the pastes, even though I spaced them out over a period of time.

- Adding newlines. I added loads of extra newlines over a Java class, by pressing Enter, moving the cursor, pressing Enter, etc. Carrying out an undo undid all of the new lines.

Both of these instances behave differently in Selena than they did in 6.0 where an "undo point" was created at the end of each action (either pasting or each press of Enter). Personally I think it would be sensible if a new "undo point" (I wish I could come up with a better description) was created when the cursor was moved.


Yes, undo behaviour became worse with 7M1. I've noticed it when changing a
line and invoking our "visual layout" plug-in which writes code. Reverting
the last operation not just reverted the code changes by "visual layout" but
also the changed line. First I thought, it is another behavior change in the
OpenAPI, but according to your other messages it looks like a new
anti-feature in 7M1.

Cast your vote at http://www.jetbrains.net/jira/browse/SELENAMS-77



Yeah I'm seeing this too. I'll be typing a bunch of code, do a smart complete, type something else, then do undo and it will go back to before the smart complete for instance. It's like the granularity of the undo has changed... for the worse :(



ps looks like there's a issue open for this here : http://www.jetbrains.net/jira/browse/IDEADEV-16429


Please sign in to leave a comment.