phpstorm refuses to indent with tabs

I've set phpstorm to use tabs and not spaces, but it seems to keep inserting spaces instead of tabs.  It also keep telling me that the file is indeted with tabs instead of 4 spaces - as if it expects me to want spaces.  Why am i getting this prompt, and how can I make phpstorm use tabs?



Attachment(s):
Screen Shot 2015-08-24 at 6.56.29 PM.png
1 comment
Comment actions Permalink

Hi there,

Why am i getting this prompt

Your screenshot is clearly shows you why. That option is highlighted.

Disable that option and see if it will behave any better.

and how can I make phpstorm use tabs

You are on "General" tab of Code Style.  Setting from specific language (PHP in your case) will override these settings here -- check the same settings but on "PHP" tab.

Another possible reason: you have EditorConfig plugin installed and enabled -- in such case settings are taken from .editorconfig file which (by nature) overrides any similar settings you set in Code Style.

0

Please sign in to leave a comment.