Import / Export settings not working

I've selected all the options for export on my laptop, exported it to dropbox.
Then on the desktop, I import the exported file.

However, live templates are missing. Specifically the group PHP. Only one template is in it, whereas on my laptop I had more.

Have tried exporting to a new file instead of overriding them, but it's still the same.

Using 9.0.1 for both.

Any help?

5 comments
Comment actions Permalink

Thanks for the info.

But when I went into the folder and checked out ~/Library/Preferences/WebIde90/templates/PHP.xml, there's only 1 entry.
Thats a custom one I'd created myself.
But the defaults (pubf, prif etc) are no where to be found.
I doubt copying that file would solve the problem.

I think the problem is that the defaults were not exported, and when imported on another machine, that machine losses the default templates.

0
Comment actions Permalink

1) "Defaults" are never stored there in Preferences in config file. They are supplied directly from plugin and therefore cannot be exported/imported.

2) If those entries are supplied by non-standard plugin then make sure it's installed and enabled.

3) The only things that stored in such config file are:
  a) your own custom entries
  b) your modifications to those default entries (e.g. it could be "deleted" mark .. or actual modifications (when you alter template to better suit your needs))

4) Based on the file name (~/Library/Preferences/WebIde90/templates/PHP.xml) you have created your own entries in default group. Better not to do it this way -- it's better to create your own entries in separate group (e.g. "My PHP") -- they will be stored in separate config file and will not interfere with defaults.

-----

You have two possible solutions here (if #2 is not the case here, of course):

1)
* Remember what your entries are;
* close IDE;
* delete that "templates/PHP.xm" file completely;
* launch IDE -- default entries should re-appear;
* recreate your own entries in separare group (as suggested in #4)

2) Live Templates screen has special button -- "Restore deleted defaults" -- see if's enabled and try using it.
screen01.png

0
Comment actions Permalink

Didn't know I shouldn't create my templates in default groups.
Yup, moving my custom templates to another custom group works fine.
Thanks.

0
Comment actions Permalink
Didn't know I shouldn't create my templates in default groups.

I did not used word "should" -- only "better not to".

It's just my own observation based on my own experience of how this system works here in IDE. By keeping your stuff in separate groups .. you reducing possible conflicts/points of failure (even of there is none at the moment they may appear in the future when new template will be added by devs which may use the same abbreviation as yours one) and making your overall experience better.

0

Please sign in to leave a comment.