6.0.1: I have a compiler. Keep getting the message "No Java compiler..."

What the heck?

Version 6.0.1

I have a compiler set, please see the attached screen shot. Why the heck am I returning the following each time I type Ctrl+F9 (Make Project)?

Error: No Java compiler available

I have restarted IntelliJ once already.

Thanks,

--Todd



Attachment(s):
intellij.gif
26 comments
Comment actions Permalink

Do you have this JDK configured for the project? The screenshot shows that you have it configured for IDEA, but you must also choose it for the project, click on the project root node and specify the Project JDK.

0
Comment actions Permalink

Serge: I believe that I have done that. Please see the new screen shot attached.

I still get this error.

Hmmm....

Thanks,

--Todd



Attachment(s):
intellij.jpg
0
Comment actions Permalink

Serge: I believe that I have done that. Please see the new screen shot attached.

I still get this error.

Hmmm....

Thanks,

--Todd



Attachment(s):
intellij.jpg
0
Comment actions Permalink

I have seen this also. I can't reproduce it consistently though.

"Todd" <no_mail@jetbrains.com> wrote in message
news:29460646.1161791639127.JavaMail.itn@is.intellij.net...

Serge: I believe that I have done that. Please see the new screen shot
attached.

>

I still get this error.

>

Hmmm....

>

Thanks,

>

--Todd



0
Comment actions Permalink

Try IDEA 6.0.2 from EAP.

If it doesn't help, reinstall the JDK, make the new JDK configuration in IDEA.

0
Comment actions Permalink

I reinstalled the JDK. I now am running 1.5.0_09.

Please see my latest screen shot.

_I still have the same error.
_
This has wasted an entire six hours of development time and since I am a paid customer, I was wondering if there was any U.S. phone support or what are my support options?

Thanks,



Attachment(s):
intellij.jpg
0
Comment actions Permalink

Have you tried IDEA 6.0.2? See here: http://jetbrains.net/confluence/display/IDEADEV/6.0.2+EAP .

We don't have phone support, support is provided here: http://www.jetbrains.com/support/idea/index.html .

Can you reproduce this problem with any project or only with this particular one?

0
Comment actions Permalink

Serge: It is with all of my projects. That's the real kicker...

I'll look at 6.0.2.

I don't understand why all of a sudden this would happen?

Thanks for helping me with this.

--Todd

0
Comment actions Permalink

Another thing that you can try is renaming USER_HOME\.IntelliJIdea60 directory and starting with the clean profile. This can help if some configuration has broken.

0
Comment actions Permalink

I have just reproduced it in 6.0.2 build 6068. It goes away if I uncheck
"Run Jasper validator for JSP files" in my web module build settings.

"Serge Baranov" <serge@jetbrains.com> wrote in message
news:1432988.1161799272518.JavaMail.itn@is.intellij.net...

Have you tried IDEA 6.0.2? See here:
http://jetbrains.net/confluence/display/IDEADEV/6.0.2+EAP .

>

We don't have phone support, support is provided here:
http://www.jetbrains.com/support/idea/index.html .

>

Can you reproduce this problem with any project or only with this
particular one?



0
Comment actions Permalink

Can you reproduce it with any project like Todd or not? Even when there are no web modules in the project?

Anything specific in your configuration?

0
Comment actions Permalink

"That solved it!!!"

Unchecking Jasper.

Geez.... What a pain in the you know what...

0
Comment actions Permalink

Well, if there's no web modules then there's no "Run Jasper validator..."
checkbox so, no I can't reproduce in projects without web modules.
One thing that may be of interest, I don't use IDEA's build, I use Ant to
build my apps so having that option selected doesn't really make sense for
me.
Although, that's not entirely true. I use IDEA's build to build for my
JUnit/Cactus tests so I can run them within IDEA. Then, I build with ant
which creates my ear. Then, I deploy that ear with IDEA (the deploy part
doesn't seem to matter since I just started doing that recently so I could
debug jsps and I was getting this error before that).

Todd, do you build/deploy with IDEA or Ant?

"Serge Baranov" <serge@jetbrains.com> wrote in message
news:550054.1161800515246.JavaMail.itn@is.intellij.net...

Can you reproduce it with any project like Todd or not? Even when there
are no web modules in the project?

>

Anything specific in your configuration?



0
Comment actions Permalink

Brad:

At the office, I use IntelliJ to build/deploy to our development environment only and I promote my projects with the Ant script though our project process.

At home, all of my projects at any stage are built/deployed with IntelliJ.

Thanks,

--Todd

0
Comment actions Permalink

Okay, I managed to find a project where I do use IDEA's build and deploy. I
don't get the error if I select "Run Jasper validator..." with that project.
But, I was expecting to get the error if I unchecked "Create web module
exploded directory" and/or "Create web module war file" since that would
basically be what my other project is setup as but I still didn't get the
error. Hope that's enough to help.

"Brad L." <no@no.no> wrote in message news:ehoba9$usq$1@is.intellij.net...

Well, if there's no web modules then there's no "Run Jasper validator..."
checkbox so, no I can't reproduce in projects without web modules.
One thing that may be of interest, I don't use IDEA's build, I use Ant to
build my apps so having that option selected doesn't really make sense for
me.
Although, that's not entirely true. I use IDEA's build to build for my
JUnit/Cactus tests so I can run them within IDEA. Then, I build with ant
which creates my ear. Then, I deploy that ear with IDEA (the deploy part
doesn't seem to matter since I just started doing that recently so I could
debug jsps and I was getting this error before that).

>

Todd, do you build/deploy with IDEA or Ant?

>

"Serge Baranov" <serge@jetbrains.com> wrote in message
news:550054.1161800515246.JavaMail.itn@is.intellij.net...

>> Can you reproduce it with any project like Todd or not? Even when there
>> are no web modules in the project?
>>
>> Anything specific in your configuration?
>



0
Comment actions Permalink

Hello Brad L.,

I need more information to reproduce the problem.
Please put the following lines into /jre/lib/logging.properties file: org.apache.jasper.JspCompilationContext.handlers=java.util.logging.FileHandler org.apache.jasper.JspCompilationContext.level=ALL Then reproduce the problem and post here ]]>/java0.log file.

Okay, I managed to find a project where I do use IDEA's build and
deploy. I don't get the error if I select "Run Jasper validator..."
with that project. But, I was expecting to get the error if I
unchecked "Create web module exploded directory" and/or "Create web
module war file" since that would basically be what my other project
is setup as but I still didn't get the error. Hope that's enough to
help.

"Brad L." <no@no.no> wrote in message
news:ehoba9$usq$1@is.intellij.net...

>> Well, if there's no web modules then there's no "Run Jasper
>> validator..."
>> checkbox so, no I can't reproduce in projects without web modules.
>> One thing that may be of interest, I don't use IDEA's build, I use
>> Ant to
>> build my apps so having that option selected doesn't really make
>> sense for
>> me.
>> Although, that's not entirely true. I use IDEA's build to build for
>> my
>> JUnit/Cactus tests so I can run them within IDEA. Then, I build with
>> ant
>> which creates my ear. Then, I deploy that ear with IDEA (the deploy
>> part
>> doesn't seem to matter since I just started doing that recently so I
>> could
>> debug jsps and I was getting this error before that).
>> Todd, do you build/deploy with IDEA or Ant?
>>
>> "Serge Baranov" <serge@jetbrains.com> wrote in message
>> news:550054.1161800515246.JavaMail.itn@is.intellij.net...
>>
>>> Can you reproduce it with any project like Todd or not? Even when
>>> there are no web modules in the project?
>>>
>>> Anything specific in your configuration?
>>>


0
Comment actions Permalink

I added the lines to logging.properties and reproduced the problem but I
don't see a java0.log file anywhere.

"Nikolay Chashnikov (JetBrains)" <Nikolay.Chashnikov@jetbrains.com> wrote in
message news:c8a894377e658c8caf30b71a6fa@news.intellij.net...

Hello Brad L.,

>

I need more information to reproduce the problem.
Please put the following lines into
<WEB_MODULE_JDK_HOME>/jre/lib/logging.properties file:

>

org.apache.jasper.JspCompilationContext.handlers=java.util.logging.FileHandler
org.apache.jasper.JspCompilationContext.level=ALL

>

Then reproduce the problem and post here <USER_HOME>/java0.log file.

>
>> Okay, I managed to find a project where I do use IDEA's build and
>> deploy. I don't get the error if I select "Run Jasper validator..."
>> with that project. But, I was expecting to get the error if I
>> unchecked "Create web module exploded directory" and/or "Create web
>> module war file" since that would basically be what my other project
>> is setup as but I still didn't get the error. Hope that's enough to
>> help.
>>
>> "Brad L." <no@no.no> wrote in message
>> news:ehoba9$usq$1@is.intellij.net...
>>
>>> Well, if there's no web modules then there's no "Run Jasper
>>> validator..."
>>> checkbox so, no I can't reproduce in projects without web modules.
>>> One thing that may be of interest, I don't use IDEA's build, I use
>>> Ant to
>>> build my apps so having that option selected doesn't really make
>>> sense for
>>> me.
>>> Although, that's not entirely true. I use IDEA's build to build for
>>> my
>>> JUnit/Cactus tests so I can run them within IDEA. Then, I build with
>>> ant
>>> which creates my ear. Then, I deploy that ear with IDEA (the deploy
>>> part
>>> doesn't seem to matter since I just started doing that recently so I
>>> could
>>> debug jsps and I was getting this error before that).
>>> Todd, do you build/deploy with IDEA or Ant?
>>>
>>> "Serge Baranov" <serge@jetbrains.com> wrote in message
>>> news:550054.1161800515246.JavaMail.itn@is.intellij.net...
>>>
>>>> Can you reproduce it with any project like Todd or not? Even when
>>>> there are no web modules in the project?
>>>>
>>>> Anything specific in your configuration?
>>>>
>



0
Comment actions Permalink

Hello Brad L.,

Looks like you have log4j.jar in classpath of your module so commons-logging uses log4j's loggers instead of JDK's loggers.

Please create directory "dir" in ]]>/lib/rt/jasper2 and put the attached commons-logging.properties file into the created directory. Then repeat steps described in my previous comment.

I added the lines to logging.properties and reproduced the problem but
I don't see a java0.log file anywhere.

>

"Nikolay Chashnikov (JetBrains)" <Nikolay.Chashnikov@jetbrains.com>
wrote in message news:c8a894377e658c8caf30b71a6fa@news.intellij.net...

>
>> Hello Brad L.,
>>
>> I need more information to reproduce the problem.
>> Please put the following lines into
>> /jre/lib/logging.properties file: >> org.apache.jasper.JspCompilationContext.handlers=java.util.logging.Fi >> leHandler org.apache.jasper.JspCompilationContext.level=ALL >> >> Then reproduce the problem and post here /java0.log file. >> >>> Okay, I managed to find a project where I do use IDEA's build and >>> deploy. I don't get the error if I select "Run Jasper validator..." >>> with that project. But, I was expecting to get the error if I >>> unchecked "Create web module exploded directory" and/or "Create web >>> module war file" since that would basically be what my other project >>> is setup as but I still didn't get the error. Hope that's enough to >>> help. >>> >>> "Brad L." wrote in message >>> news:ehoba9$usq$1@is.intellij.net... >>>> Well, if there's no web modules then there's no "Run Jasper >>>> validator..." >>>> checkbox so, no I can't reproduce in projects without web modules. >>>> One thing that may be of interest, I don't use IDEA's build, I use >>>> Ant to >>>> build my apps so having that option selected doesn't really make >>>> sense for >>>> me. >>>> Although, that's not entirely true. I use IDEA's build to build for >>>> my >>>> JUnit/Cactus tests so I can run them within IDEA. Then, I build >>>> with >>>> ant >>>> which creates my ear. Then, I deploy that ear with IDEA (the deploy >>>> part >>>> doesn't seem to matter since I just started doing that recently so >>>> I >>>> could >>>> debug jsps and I was getting this error before that). >>>> Todd, do you build/deploy with IDEA or Ant? >>>> "Serge Baranov" wrote in message >>>> news:550054.1161800515246.JavaMail.itn@is.intellij.net... >>>> >>>>> Can you reproduce it with any project like Todd or not? Even when >>>>> there are no web modules in the project? >>>>> >>>>> Anything specific in your configuration? >>>>>]]>

Attachment not added (general error): "commons-logging.properties"

0
Comment actions Permalink

The latest build (6077) seems to have fixed the problem. Thanks.

"Nikolay Chashnikov (JetBrains)" wrote in message news:c8a894377ec38c8cbb9329f6387@news.intellij.net... Hello Brad L., Looks like you have log4j.jar in classpath of your module so commons-logging uses log4j's loggers instead of JDK's loggers. Please create directory "dir" in ]]>/lib/rt/jasper2 and put the
attached commons-logging.properties file into the created directory. Then
repeat steps described in my previous comment.

I added the lines to logging.properties and reproduced the problem but
I don't see a java0.log file anywhere.

>

"Nikolay Chashnikov (JetBrains)" <Nikolay.Chashnikov@jetbrains.com>
wrote in message news:c8a894377e658c8caf30b71a6fa@news.intellij.net...

>
>> Hello Brad L.,
>>
>> I need more information to reproduce the problem.
>> Please put the following lines into
>> /jre/lib/logging.properties file: >> org.apache.jasper.JspCompilationContext.handlers=java.util.logging.Fi >> leHandler org.apache.jasper.JspCompilationContext.level=ALL >> >> Then reproduce the problem and post here /java0.log file. >> >>> Okay, I managed to find a project where I do use IDEA's build and >>> deploy. I don't get the error if I select "Run Jasper validator..." >>> with that project. But, I was expecting to get the error if I >>> unchecked "Create web module exploded directory" and/or "Create web >>> module war file" since that would basically be what my other project >>> is setup as but I still didn't get the error. Hope that's enough to >>> help. >>> >>> "Brad L." wrote in message >>> news:ehoba9$usq$1@is.intellij.net... >>>> Well, if there's no web modules then there's no "Run Jasper >>>> validator..." >>>> checkbox so, no I can't reproduce in projects without web modules. >>>> One thing that may be of interest, I don't use IDEA's build, I use >>>> Ant to >>>> build my apps so having that option selected doesn't really make >>>> sense for >>>> me. >>>> Although, that's not entirely true. I use IDEA's build to build for >>>> my >>>> JUnit/Cactus tests so I can run them within IDEA. Then, I build >>>> with >>>> ant >>>> which creates my ear. Then, I deploy that ear with IDEA (the deploy >>>> part >>>> doesn't seem to matter since I just started doing that recently so >>>> I >>>> could >>>> debug jsps and I was getting this error before that). >>>> Todd, do you build/deploy with IDEA or Ant? >>>> "Serge Baranov" wrote in message >>>> news:550054.1161800515246.JavaMail.itn@is.intellij.net... >>>> >>>>> Can you reproduce it with any project like Todd or not? Even when >>>>> there are no web modules in the project? >>>>> >>>>> Anything specific in your configuration? >>>>>]]>


0
Comment actions Permalink

I'm still having this problem with IDEA 6.0.4 (build 6148). It's a web module that is being deployed to a JBoss server.

Unchecking the "Run Jasper validation" does fix the issue. Do I need to open a JIRA for this?

Tobin

0
Comment actions Permalink

Hello Tobin,

Yes.

I'm still having this problem with IDEA 6.0.4 (build 6148). It's a
web module that is being deployed to a JBoss server.

Unchecking the "Run Jasper validation" does fix the issue. Do I need
to open a JIRA for this?

Tobin



0
Comment actions Permalink

same here.

Project with a web module with "create exploded" unselected and "run jasper validation" selected gives the "no compiler" message.

Unselecting "run jasper validation" solves it

0
Comment actions Permalink

brad,How about solving it in netbeans?
thanks!!!!!!!!!

0
Comment actions Permalink

solve what? It works as it should.

0
Comment actions Permalink

I can load the JSP in TOMCAT,while it give the message"no java compiler availabel" after I install JWSDP.

0

Please sign in to leave a comment.