Checking out project from svn > Cannot run program "svn"

Hi,

I just reinstalled my development machine, and PHPStorm 9.

I am trying to check out my project from SVN, but I get the follow error:
Cannot run program "svn" (in directory "...my project directory..."): CreateProcess error=2, The system cannot find the file specified.

PHPStorm is fresh out of the installation, no setting has been changed.

I am running on Windows 10.

Any idea what the issue is?

Best regards

4 comments
Comment actions Permalink

Please open Settings>Version Control>Subversion and specify a full path to your Subversion client instead of just 'svn' in 'Use command line client' field

0
Comment actions Permalink

By any chance, would you know what the path of the SVN client is? As far as I understood, PHPStorm is providing one out of the box right?

0
Comment actions Permalink

As far as I understood, PHPStorm is providing one out of the box right?

No, not exactly so... It depends on your SVN working copy version. Let's make things clear: PHPStorm indeed bundles the svnkit  (third-party library) to work with SVN. But this library doesn't support  SVN 1.8. So, for the svn1.8 working copies the external client is  required, PHPStorm can't work if the path to svn1.8 command line client  is not set in Settings/VersionControl/Subversion.
So,
1) for svn1.6 working copies svnkit is used for all operations always
2) for svn1.7 working copies svnkit is used unless the  Settings/VersionControl/Subversion/Use command line client option is  enabled, and the
path to valid svn1.7 client is specified
3) for svn1.8 working copies the external svn1.8 command line client is used; path to this client should be set; the value of
Settings/VersionControl/Subversion/Use command line client option is ignored - PHPStorm will try using external client even if this option is off.

So, if you need using svn 1.8, the only option is to install the command line client. Try the http://www.collab.net/downloads/subversion, for example

0
Comment actions Permalink

Actually since I had no working copy, I had no version set.

But your answer gave me the idea to try to simply uncheck the "use the command line" checkbox and now it works. And then, when asked, I picked SVN 1.7 to be sure. And now it works

Thank you very much

1

Please sign in to leave a comment.