Remote application crash when doing remote debugging.

Does anyone have solve this problem?

I have :

(1) InteliJ 3.0
(2) Remote application runs under JDK1.3.1_06 - tried other version as well ie 1.3.1_04, or 1.4
(3) Windows 2000 Professional
(4) P4, 700Mb Ram
(5) Remote debugging settings socket connection port 6666


4 comments

Oh btw, here's the error message I recieve.

The instruction at "0x6d478b47" referenced memory at "0x11134000". The memory could not be "written".

Click on OK to terminate the program
Click on Cancel to debug the program.

0

Also, this problem is occur on JBuilder 7 as well.

Could it be that the Window 2000 Professional causing this? I never had this problem on W2K Server and on WXP

0

This is probably because you are using shmem transport for connection. In JDKs 1.3.x its implementation has problems that may result
in the error you described. Use socket transport: it is far more stable.

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

"Servitoa" <jiveadmin@jetbrains.com> wrote in message news:3858503.1043951961358.JavaMail.jrun@is.intellij.net...

Also, this problem is occur on JBuilder 7 as well.

>

Could it be that the Window 2000 Professional causing this? I never had this problem on W2K Server and on WXP



0

I had similar problems with intelliJ (build #701) on remote debugging when working with weblogic 6.1.

But i made sure the remote application is run using a
-classic option and intellij's FORCE Classic VM option to 'CHECKED'

This has reduced the remote application a lot.

0

Please sign in to leave a comment.