Anyone having a problem with the editor screwing up linefeeds?


Sometimes I seem to get the linefeeds all screwed up.

-- Glen

2 comments

What exactly is the problem?

It happened to me occasionally that some source files suddenly had two linefeeds instead of one, so having a lot of empty lines in them.

I guess the reason was editing the file on both Windows and Linux, but I am not sure what made the problem disappear:
In IDEA project settings (code style) I have set "Line Separator (for new files)" to "\n" and I also made sure not to use the Unix cvs client on Windows (with cygwin).

Stephen

0

Stephen Kelvin wrote:

What exactly is the problem?

It happened to me occasionally that some source files suddenly had two linefeeds instead of one, so having a lot of empty lines in them.

I guess the reason was editing the file on both Windows and Linux, but I am not sure what made the problem disappear:
In IDEA project settings (code style) I have set "Line Separator (for new files)" to "\n" and I also made sure not to use the Unix cvs client on Windows (with cygwin).

Stephen


I've seen that too. Sometimes though it seems to compress all lines
into a single line when I commit to CVS. I haven't found out a pattern
to when this happens though.

I might try to set my linefeeds to \n also.

Regards,

Glen

0

Please sign in to leave a comment.