Cannot add build file to Ant Build tool window?

I cannot add an ant file to the Ant Build tool window! I started a new project, selected New > File, named it build.xml. It turned up in my src folder, which is okay for now, then I right-click on it and choose: Add as Ant Build file and I get the follow error message:

Cannot add build files from excluded directories:
C:\bin\cygwin\home\ftravers\projects\project3\src\build.xml

I go to the project settings and that dir is marked as a source folder so I would say that it IS included. Any ideas?

I've attached screen shots...

Thanks.



Attachment(s):
error1.jpg
error2.jpg
3 comments
Comment actions Permalink

You have to write at least ]]> into the file before
adding it as an ant file. Else it isn't recognized as a valid ant file.
(I consider this a bug, so feel free to file a JIRA request.)

Fenton wrote:

I cannot add an ant file to the Ant Build tool window! I started a new project, selected New > File, named it build.xml. It turned up in my src folder, which is okay for now, then I right-click on it and choose: Add as Ant Build file and I get the follow error message:

Cannot add build files from excluded directories:
C:\bin\cygwin\home\ftravers\projects\project3\src\build.xml

I go to the project settings and that dir is marked as a source folder so I would say that it IS included. Any ideas?

I've attached screen shots...

Thanks.


------------------------------------------------------------------------


------------------------------------------------------------------------

0
Comment actions Permalink

AFAIK the project roottag is required, so a build file missing it isn't valid.

0
Comment actions Permalink

Hello Fenton,

Martin is right, and here is existing JIRA usability issue:
http://www.jetbrains.net/jira/browse/IDEADEV-14784

I cannot add an ant file to the Ant Build tool window! I started a
new project, selected New > File, named it build.xml. It turned up in
my src folder, which is okay for now, then I right-click on it and
choose: Add as Ant Build file and I get the follow error message:

Cannot add build files from excluded directories:
C:\bin\cygwin\home\ftravers\projects\project3\src\build.xml
I go to the project settings and that dir is marked as a source folder
so I would say that it IS included. Any ideas?

I've attached screen shots...

Thanks.

Alexander.


0

Please sign in to leave a comment.