Working with debugger using IntelliJ 6 - is very slow

Ever since I upgraded from version 5 to version 6, I cannot work under debugger.
My application runs unreasonably slow when debugger is attached (when I detached it - it returns to normal performance).

It didn't happen in previous versions.

My cache IntelliJ cache was expaned to 512 Mega, and still the problem exists.

Any fix exists to that ?
Any resource I should change ?

21 comments
Comment actions Permalink

Make sure there are no method breakpoints defined for methods or code that no longer exists. You might just want to delete all your breakpoints and start over.

0
Comment actions Permalink

ruthie wrote:

Ever since I upgraded from version 5 to version 6, I cannot work under debugger.
My application runs unreasonably slow when debugger is attached (when I detached it - it returns to normal performance).

It didn't happen in previous versions.

My cache IntelliJ cache was expaned to 512 Mega, and still the problem exists.

Any fix exists to that ?
Any resource I should change ?


What OS are you running it under? There is a problem with Java and
certain Linux kernels that make debugging painfully slow. Issue this
command (either as root or with sudo) to fix it for the session:
sysctl -w net.ipv4.tcp_abc=0


-cr

0
Comment actions Permalink

Do not set "Enable 'toString' object view" in Debugger obtions.

toString() takes a lot of time for each object while debugging code.

If you want you can add some classes you want to inspect with 'toString()' evry time.

PS: For debugging non-remote applikations I use for Transport "shared memory" instead of "Socket" this is realy faster.

Greetings
Henne

0
Comment actions Permalink

I tried that and it didn't help in my case

0
Comment actions Permalink

I removed all breakpoints and added only one.
It is still very very slow, impossible to work with.

0
Comment actions Permalink

I am using Windows XP not Linux.

0
Comment actions Permalink

which port do you use for debugging (if it's remote...)? I would suggest smth higher then 5500

0
Comment actions Permalink

Please enable self-profiling like described here:
http://support.jetbrains.com/kb/entry.jspa?categoryID=5&externalID=192
and take several CPU snapshots while debugging the code. Please send these snapshots to me directly.

Also check whether the "Any exception breakpoint" is enabled or there are any condition expressions assigned to your breakpoint.

Thanks in advance.

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

"ruthie" <no_mail@jetbrains.com> wrote in message news:13828008.1165499408602.JavaMail.itn@is.intellij.net...

Ever since I upgraded from version 5 to version 6, I cannot work under debugger.
My application runs unreasonably slow when debugger is attached (when I detached it - it returns to normal performance).

>

It didn't happen in previous versions.

>

My cache IntelliJ cache was expaned to 512 Mega, and still the problem exists.

>

Any fix exists to that ?
Any resource I should change ?



0
Comment actions Permalink

already done, didn't help

0
Comment actions Permalink

Tried that, seems to work once but on second try slowdown returned

0
Comment actions Permalink

Tried that , still very slow

0
Comment actions Permalink

Thanks.

I send you the data directly via email

0
Comment actions Permalink

Have u solved the issue, cause I'm have the same problem?

Thanks
Oded

0
Comment actions Permalink

No, I am afraid not.

0
Comment actions Permalink

Hi Eugene,

I am also suffering from the same problem.
It is quite annoying. I would be interested in your fix once found.

Thanks, Nir.

0
Comment actions Permalink

It is quite annoying. I would be interested in your fix once found.


Would be nice to get the snapshot from you as well :)

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

"Nir" <no_mail@jetbrains.com> wrote in message news:32933927.1166101898794.JavaMail.itn@is.intellij.net...

Hi Eugene,

>

I am also suffering from the same problem.
It is quite annoying. I would be interested in your fix once found.

>

Thanks, Nir.



0
Comment actions Permalink

Hi,
I also have the same problem (also opened a call in this forum) - which caused me to return to version 5.
I'll send to you also these snapshots by mail - hope it will help.
Bye,
Rachely

0
Comment actions Permalink

Hi Oded,

It seems I had a Method breakpoint defined (by mistake I guess).
This caused the slowdown. Removing this breakpoint returned to normal performance.
Check breakpoint window, press the Method tab.

0
Comment actions Permalink

Is this still a problem?
Someone here (who was running Intellij 6 for several weeks) ran into the problem yesterday (Jan 23) - debugging was 10 to 100 times slower than normal. After clearing the Intellij cache, the problem went away.

0
Comment actions Permalink

Mine was another problem. I had to clear method breakpoints and then it was solved.
Clearing the cache didn't help in my case.

Anyhow the problem was solved after clearing method breakpoints.

0
Comment actions Permalink

This was supposedly fixed in jdk1.5.0_08. However, we have jdk1.5.0_10 and it is still there. Fortunately, the sysctl command does successfully work around the problem.

0

Please sign in to leave a comment.