Trick to Configuring External Javadoc on OS X?

I have configured IntelliJ 3.0.4 to use Safari as the external browser and the 1.4.1 documentation at /Developer/Documentation/Java/Reference/1.4.1/doc/api, but when I do a shift-F1 on say, java.util.Hashtable, IDEA attempts to open the following URL: /Applications/IntelliJ-IDEA-3.0.4/bin/file%3A/Developer/Documentation/Java/Reference/1.4.1/doc/api/java/util/Hashtable.html. Why is it prepending this stuff? Do any of you OS X users have this working?

Thanks in advance.

8 comments

Anybody? Is this a bug or user error? I don't see a bug submitted for this, but can't imagine I am the only one with this problem.

0

What does your Web Browser path (in General IDE Settings) point to? I have it opening a script and I can get to my (local) Velocity docs or to the (network) Sun Java docs without a problem.

My script is:

#! /bin/sh
echo open location \"$1\" | osascript

0

Even simpler, you can just set your browser path to /usr/bin/open

0

Cool, I created a shell script that just does "open $1" and it is working. I didn't know about the "open" command. Kinda like doing a "start" from windoze.

Thanks much for the help.

0

Phillip E. Trewhella <ptrewhel@bridgemedical.com> wrote:

prepending this stuff? Do any of you OS X users have this working?


I got the same problem. Additionally, another Safari Icon comes up when
I try to access the Javadoc. Can you file a bug for that? I don't have
time right now...

Thanks,

Dirk Dittert

0

Dirk,

See the earlier postings -- all you need to do is set up your browser path (Options ... IDE Settings, "General" tab) to be /usr/bin/open. This will open your default browser (set up in "internet settings" from system prefs) displaying the Javadoc.

0

Ah, much nicer. I can finally toss that silly script.

0

Phillip E. Trewhella <ptrewhel@bridgemedical.com> wrote:

See the earlier postings -- all you need to do is set up your browser path
(Options ... IDE Settings, "General" tab) to be /usr/bin/open. This
will open your default browser (set up in "internet settings" from
system prefs) displaying the Javadoc.


Thank you, I already saw that.

Dirk

0

Please sign in to leave a comment.