[813]Optimizing Performance. Please wait...

Using: IDEA build 813 on Windows XP Professional

Can you tell me what IDEA is doing when I open a new project and I get the dialog that reads "Optimizing Performance. Please wait...".

I thought it was copying all the jars referenced by my project to its system cache and so I disabled it by using the "-Didea.jars.nocopy=true" setting at IDEA startup. This seemed to work once. However, when I changed the target JDK using the "Project Properties", it went through the "Optimizing...." stuff over again. The same thing happens when opening a new project, say using the File > Re-open menu.

This optimization takes forever (several minutes) and during this time it takes over the CPU.

Is there a way to side-step this "optimization"?

Sri

4 comments
Comment actions Permalink

Srivaths Sankaran wrote:

Using: IDEA build 813 on Windows XP Professional

Can you tell me what IDEA is doing when I open a new project and I get the dialog that reads "Optimizing Performance. Please wait...".

I thought it was copying all the jars referenced by my project to its system cache and so I disabled it by using the "-Didea.jars.nocopy=true" setting at IDEA startup. This seemed to work once. However, when I changed the target JDK using the "Project Properties", it went through the "Optimizing...." stuff over again. The same thing happens when opening a new project, say using the File > Re-open menu.

This optimization takes forever (several minutes) and during this time it takes over the CPU.

Is there a way to side-step this "optimization"?

Sri


Or optimize in background would be nice.


0
Comment actions Permalink

This mostly happens the first time you open the project, subsequent times it is much faster.
It is also necessary for various actions by the IDE. Unless you are constantly switching
JDK's, this shouldn't be a problem.

Srivaths Sankaran wrote:

Using: IDEA build 813 on Windows XP Professional

Can you tell me what IDEA is doing when I open a new project and I get the dialog that reads "Optimizing Performance. Please wait...".

I thought it was copying all the jars referenced by my project to its system cache and so I disabled it by using the "-Didea.jars.nocopy=true" setting at IDEA startup. This seemed to work once. However, when I changed the target JDK using the "Project Properties", it went through the "Optimizing...." stuff over again. The same thing happens when opening a new project, say using the File > Re-open menu.

This optimization takes forever (several minutes) and during this time it takes over the CPU.

Is there a way to side-step this "optimization"?

Sri



--

Erb

==============================================================
"Most of you are familiar with the virtues of a programmer.
There are three, of course: laziness, impatience, and hubris."
- Larry Wall
==============================================================

0
Comment actions Permalink

I think it takes way too much time on a large project and is annoying. It seems to go through exactly the same process every time a project is opened. Also, I don't see the performance of the editor improve in any perceptible way after this process completes.

Is this "optimization" just a process of caching? Can this be disabled or as Glen suggested, put in the background?

Sri

0
Comment actions Permalink

On Wed, 23 Apr 2003 09:54:59 -0400, Erb wrote:

This mostly happens the first time you open the project, subsequent times
it is much faster. It is also necessary for various actions by the IDE.
Unless you are constantly switching JDK's, this shouldn't be a problem.


I wonder if its possible to do this optimize as a non-gui task, so then I
could run it from my personal crontab each morning at say 7am - that way
whenever I get to work, its all freshly optimized for my projects :)


0

Please sign in to leave a comment.