Some annoying window behaviours

On occasion, when doing a CTRL/F to bring up the find dialog, the dialog comes up maximized.

Also, it is not uncommon for an opened window to come up with a title bar only. Sometimes when this happens, it continues to happen for every dialog box opened thereafter. When that happens, one cannot close the application, because there is no way to answer the confirm exit dialog, so one has to actually kill the application. Upon an application restart, everything is well again.

This happens in both Windows XP and Linux. I'm currently using version 6.0.2, but I believe this has happened with prior releases, though,as a relative newcomer, I have not used many prior releases.

9 comments
Comment actions Permalink

Very strange, I've never seen this behaviour in any build of IDEA, and I've
used plenty :) My first thought was that you had some 3rd party window manager
software running, but you say it happens on more than one OS so I guess it's
not that. Have you tried exiting IDEA and deleting your entire system directory
(~/.IntelliJIdea60/system) to see if that helps? You won't lose any settings,
but IDEA will take a while to start up since it'll need to rebuild all its
caches.

Another idea is to hand-edit ~/.IntelliJIdea60/config/options/other.xml to
get rid of the "DimensionService" component. Take a backup of other.xml first
though, since I've never tried doing that myself!

Also, you could try the latest EAP build #6117 (http://www.intellij.net/eap).

As for exiting IDEA, you should be able to just press enter or space to select
OK (or alternatively turn off the exit confirmation).

Hope one of the above helps!

Chris

On occasion, when doing a CTRL/F to bring up the find dialog, the
dialog comes up maximized.

Also, it is not uncommon for an opened window to come up with a title
bar only. Sometimes when this happens, it continues to happen for
every dialog box opened thereafter. When that happens, one cannot
close the application, because there is no way to answer the confirm
exit dialog, so one has to actually kill the application. Upon an
application restart, everything is well again.

This happens in both Windows XP and Linux. I'm currently using
version 6.0.2, but I believe this has happened with prior releases,
though,as a relative newcomer, I have not used many prior releases.



0
Comment actions Permalink

Well, it doesn't happen so often. The maximise thing happens maybe once or twice per day, and the "title bar only" issue every couple of days. I can live with it the way it is.

Let me verify that both behaviours occur also on Windows. I might be mistaken regarding the "title bar only" issue on Windows. It will be next week before I use IDEA on Windows again, but I'll post back when I get new info.

Thanks for the response!

0
Comment actions Permalink

I see the maximized Find dialog symptom, occasionally, too.

I also sometimes see dialogs shaded or with zero vertical size. If shaded, they can be unshaded (I've configured my KDE to shade/unshade upon double-clicking a window's title bar). If zero size, then the close box must be clicked and the command the produced the dialog re-invoked.

It may be a Java thing, since I've seen the shaded and zero-size dialog symptom in other Java applications (jEdit comes to mind).

RRS

0
Comment actions Permalink

I can confirm this on linux. I have read in the bug database of idea
(famous cursor focus bug) someone else suffers from it. I'm rather sure
it is a java bug and have searched for it in the sun database but not
found yet. Perhaps we should look again and open one if not found. If
you find one let me know because it is annoying.

Do you have a special uncommon window behavior setting in windows (focus
follows mouse), or mouse goes to default button? Perhaps this is related
but I'm just shooting blind.

Thomas

Rich Downing wrote:

On occasion, when doing a CTRL/F to bring up the find dialog, the dialog comes up maximized.

Also, it is not uncommon for an opened window to come up with a title bar only. Sometimes when this happens, it continues to happen for every dialog box opened thereafter. When that happens, one cannot close the application, because there is no way to answer the confirm exit dialog, so one has to actually kill the application. Upon an application restart, everything is well again.

This happens in both Windows XP and Linux. I'm currently using version 6.0.2, but I believe this has happened with prior releases, though,as a relative newcomer, I have not used many prior releases.

0
Comment actions Permalink

In LInux/KDE I do have "focus follows mouse" set.

By the way, in the application I'm developing, on occasion when I open up the file dialog to open a file, it is "title bar only" or "zero length window" however one wants to phrase it. I haven't noticed it yet when executing from a jar file. As I'm developing, I'm usually executing from within IDEA.

I think I may have to back off the statement that I've seen this in Windows. At least the part where I had to kill the application. I think the application froze for another reason. Perhaps I can get more info next week.

I'm rewriting an application that I first wrote 6 - 7 years ago. I never notice this issue when executing that original application. Don't remember with which version of Java it was compiled.

0
Comment actions Permalink

Hi, all. I've been having the same problems with shaded and maximized dialogs. I believe the problems only occur for me on KDE, not Gnome or Windows.

I don't to my knowledge have any unusual window settings.

Contrary to what someone earlier up this thread said, I am able to close the dialogs even when they are shaded, by clicking the X button on the title bar.

Regards,
Keith

0
Comment actions Permalink

Hi, folks. I've had some success with a workaround. I went to the KDE Control Center (System Settings menu item in Kubuntu), selected "Regional & Accessibility", then "Keyboard Shortcuts", and assigned Ctrl-Shift-F12 to Windows/Shade Window.

Now when I get the shading problem, I press Ctrl-Shift-F12 a few times, sometimes even holding it down for a few seconds, and often I get the window to display properly.

Not a fix, but a workaround...

Hope that helps,
Keith

0
Comment actions Permalink

Interesting sleuthing. I've set up keyboard shortcut and will give it a try the next time I experience the problem. I'll report back how it worked.

0
Comment actions Permalink

It worked fine. Saves me some time. Thanks for the tip.

0

Please sign in to leave a comment.