Question about opening projects

Hi everyone,

I have a problem. When I charged the project of my company, it always takes a
lot of time parsing files and sometimes it shows a message of low memory.
How can I disable that, or it's always done????

Thanks in advance

Mauricio

2 comments
Comment actions Permalink

Hi Mauricio,

there are a few things that might be related.

Opening projects:
If you don't want your last project to open on startup : Settings | General | Reopen last project on startup

Switching applications / refreshing:
If you don't want idea to check for external changes on activation of the frame (e.g. when you switch back from an other application or other idea project/frame: Settings | General | Synchronize files on frame activation

Available memory settings:
If you want to allow idea to use more memory: check the idea.exe.vmoptions file, which is located in /bin. In there you can (amongst others) specify the maximum amount of memory idea can allocate with the -Xmx property

0
Comment actions Permalink

Thanks Ruben

I decided to configure IntelliJ to don't check for external changes on activation of the frame, and I increase the memory in the file idea.exe.vmoptions. It helps me a lot.

Thanks again,
Mauricio

0

Please sign in to leave a comment.