How to setup Chrome to solve "windows cannot find chrome" under debugging Dart

I'm a newbie...

I have been using Webstorm to run and debug my Dart 1.10 web app. I also had DartEditor intsalled with Dartium.

I have upgraded to Dart SDK to 1.11 (so no more DartEditor or Dartium).

I can do a normal run - Chrome fires up OK.  But when I do a debug, I get the error:

"Windows cannot find Chrome. Make Sure you have typed the name correctly".  This also pops up when I try to "ensure that JetBrains is installed".

Also, in the old SDK I had a link to Dartium and debug fired up in that. I've faffed around in the setup/tools and added new Chromes - and deleted them etc, but to no avail.

What do I need to do to in my settings please?
Thanks
cheers
Steve

4 comments
Comment actions Permalink

Please make sure that 'Chrome' is selected as a 'Browser' in JavaScript Debug run configuration you use for debugging, and that the full path to Chrome executable is set in Settings/Tools/Web Browsers (instead of just 'chrome')

0
Comment actions Permalink

Hi,
Thanks for your response.

Just spent at least 4 hours trying to get it to work and getting very frustrated and fed up  Chrome runs fine - it's all I use.

1) Deleted the .idea folder.

2) Uninstalled Webstorm, reinstalled, cold reboot. Re-entered my licence.

3) Created a new project from my existing project files.

4) Right clicked on the main.html and run - it runs in Chrome immediately.

5) Right click and select debug - and it can't find Chrome.

So, in settings/tools/web browsers, do I deselect Chrome from the default top list, and then in the "default browser", make it "Custom", and set the complete Chrome path there?  Well, I have tried that and JB says it can't find Chrome.  When I open Chrome the JB extension is installed - and the JB icon is there too.

It used to work!?!

I see there is a new version of Webstorm.  Is that a free upgrade for licenced users (I just bought my licence)? Any chance it addresses my problem?

regards
Steve

0
Comment actions Permalink

Hi Elena,

Solved - sort of.  I have selected Dartium instead, and debug now works.  But I only had Dartium because I have the Dart Editor installed. So I don't know if that's an issue for JB.

On a related point, the JB notification is continually popping up saying "Please ensure Jetbrains IDE support is installed in Chromium".  To avoid this, I have to leave Chromium/Dartium open all the time. If I do close the browser, and the start Chromium directly, it says JB extension is enabled. But if I start the debugger, it won't run until I accept the JB notification to install the extension.

cheers
Steve

0
Comment actions Permalink
So, in settings/tools/web browsers, do I deselect Chrome from the default top list, and then in the "default browser", make it "Custom", and set the complete Chrome path there?


No, nothing of the kind. You just need to specify a full path to browser executable next to Chrome in browsers list:

chrome.png


By default, WebStorm starts Chrome by name (executes 'start chrome' command). Seems this command doesn't work on your system, that's why you need to make sure to specify a full path to executable instead of the shorthand ('chrome')

0

Please sign in to leave a comment.