Breakpoints stopped working

Breakpoints are no longer working in my Meteor/Javascript debugger.  I see solid red dot, and Jetbrains flag in Chrome, but it never hits any of them.

I'm using latest 10.0.3 with latest Chrome Version 43.0.2357 on OSX 10.10.3
tried re-install of either base or Java 1.8 bundle. Neither work.

My meteor/JS debug config is correct and the same as it always is.

Might be tied to the recent update becuase I just started seeing it.

Any ideas?



Are you using sourcemaps in your application? Debugging using sourcemaps has stopped working since Chrome 43.0.2357.65 update


Not that I am aware of.  I'm just using the default Meteor configuration.


How can I get a download of 10.0.0 or older?  I need to downgrade to see if it solves this problem since it just started on its own.


Issue is with debugging client-side code inside local meteor packages.  Just quit working in Webstorm.  server-side is fine.  So, it must be something with the javascript debugger no longer being compatible with latest meteor.

Wasted an entire day/night trying to get it to work again! Not cool.

Anyone else have issues debugging meteor in 10.0.3 with latest meteor?



Elena, Thanks for the update.

   I am using sourcemaps, and I am seeing this in Rubymine and Webstorm. Any report on when this can be fixed?


Please follow for updates. Fix is in progress...


this is still not resolved, I'm having the same issues with the Typescript breakpoints.. just got this error in the Event Log Window :

13:04:24 NullPointerException: null

 at com.jetbrains.javascript.debugger.LineBreakpointManagerImpl.getVmBreakpointManager(
 at com.jetbrains.javascript.debugger.LineBreakpointManagerImpl.doSetBreakpoint(
 at com.jetbrains.javascript.debugger.LineBreakpointManagerImpl.setBreakpoint(
 at com.jetbrains.javascript.debugger.LineBreakpointManagerImpl.setBreakpoint(
 at com.jetbrains.javascript.debugger.LineBreakpointHandler.registerBreakpoint(
 at com.jetbrains.javascript.debugger.LineBreakpointHandler.registerBreakpoint(
 at com.intellij.xdebugger.impl.XDebugSessionImpl.a(
 at com.intellij.xdebugger.impl.XDebugSessionImpl.a(
 at com.intellij.xdebugger.impl.XDebugSessionImpl.a(
 at com.intellij.xdebugger.impl.XDebugSessionImpl.access$2100(
 at com.intellij.xdebugger.impl.XDebugSessionImpl$MyBreakpointListener.breakpointAdded(
 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 at sun.reflect.NativeMethodAccessorImpl.invoke(
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(
 at java.lang.reflect.Method.invoke(
 at com.intellij.util.EventDispatcher.dispatch(
 at com.intellij.util.EventDispatcher.access$100(
 at com.intellij.util.EventDispatcher$1.invoke(
 at com.sun.proxy.$Proxy67.breakpointAdded(Unknown Source)
 at com.intellij.xdebugger.impl.breakpoints.XBreakpointManagerImpl.a(
 at com.intellij.xdebugger.impl.breakpoints.XBreakpointManagerImpl.addLineBreakpoint(
 at com.intellij.xdebugger.impl.XDebuggerUtilImpl$
 at com.intellij.openapi.application.WriteAction$1$
 at com.intellij.openapi.application.impl.ApplicationImpl.runWriteAction(
 at com.intellij.openapi.application.WriteAction$
 at com.intellij.openapi.application.WriteAction.execute(
 at com.intellij.xdebugger.impl.XDebuggerUtilImpl.toggleAndReturnLineBreakpoint(
 at com.intellij.xdebugger.impl.breakpoints.XBreakpointUtil.toggleLineBreakpoint(
 at com.intellij.xdebugger.impl.breakpoints.XLineBreakpointManager$MyEditorMouseListener$1$
 at com.intellij.openapi.application.impl.LaterInvocator$
 at java.awt.event.InvocationEvent.dispatch(
 at java.awt.EventQueue.dispatchEventImpl(
 at java.awt.EventQueue.access$500(
 at java.awt.EventQueue$
 at java.awt.EventQueue$
 at Method)
 at java.awt.EventQueue.dispatchEvent(
 at com.intellij.ide.IdeEventQueue.e(
 at com.intellij.ide.IdeEventQueue._dispatchEvent(
 at com.intellij.ide.IdeEventQueue.dispatchEvent(
 at java.awt.EventDispatchThread.pumpOneEventForFilters(
 at java.awt.EventDispatchThread.pumpEventsForFilter(
 at java.awt.EventDispatchThread.pumpEventsForHierarchy(
 at java.awt.EventDispatchThread.pumpEvents(
 at java.awt.EventDispatchThread.pumpEvents(

I tried all the suggested tricks :

- downgraded to Chrome 42
- used the latest Early acces PHPStorm , as well as the v141.1340

no joy!

still not stopping on Typescript breakpoints ! :(


Exception looks similar to But it shouldn't normally affect breakpoints set before the debug session is started.
Please can you attach a sample project that shows up your issue?


Hi Elena

Sorry the whole project files are confidential, but actually after the restart this error wasn't comming up anymore.


Please sign in to leave a comment.