IntelliJ 6 seems to "forget" about my changed files between sessions

Hi everyone,

At my company, everyone uses IntelliJ. Until recently, most of us were using 4.5.4, but we had a few 5.x licenses, and I was lucky enough to have one, so I got to use 5.1.2.

When the public beta release of IntelliJ 6 came out, I downloaded it and tried it out. I opened up my project and began working. Everything seemed fine at first. At the end of the day, I had maybe 15 added or modified files. The filenames appeared in blue to indicate that they were changed, or green to indicate that they were new. I closed IntelliJ and logged off.

The next day, I opened up IntelliJ again. All of the files I had open before were still open, but only two of them were marked in blue and none in green. I looked at the files, and my changes were still there. The "Changes" sidebar did not reflect the changes either.

I did a CVS Project Update. IntelliJ "discovered" that a couple more files were changed, so now four of them were marked in blue.

I selected one of the files that I knew was modified, but was not marked in blue. I did a CVS update on that individual file and it turned blue. Tried it again on another -- that worked too.

I selected one of the files that was added (and not marked in green). CVS Update was greyed out. CVS Add was available, as if the file had not previously been added. I tried that and it worked -- the file turned green.

The Commit dialog only offered to commit files that were marked as changed, which meant that I had a whole bunch of hoops to jump through if I wanted to commit everything.

I reverted to 5.1.2. We are currently in the process of upgrading everyone to new machines with 6.0 licenses. I am once again lucky enough to be one of the first developers to get an updated license. So I tried using 6.0.1 for a few days (this was a couple weeks ago). Same problem, so I reverted again.

Later, 6.0.2 came out, so I tried that. It exhibited the exact same behavior, so now I'm back on 5.1.2 again.

At this point, a few other developers here are using 6.0.2, and none of them have encountered this problem.

Does anyone have any idea what might be causing this?




Hi Jake,
I think that I have the same problem but I haven't received any answer.

Please, can anyone help us?.



Hi Piere,

I agree, it sounds like we have the same problem.

Are you using any nonstandard IntelliJ plugins?

I am using TabReorder and CVS Bar. I have tried removing CVS Bar, but the problem persists.



Hi Jake,
I think that the only nonstandard IntelliJ plugin that I have installed is CVS Bar. I attach a jpg with all the installed plugins.



Please sign in to leave a comment.