IntelliJ 6 - Debugger works very very slow

Since I have upgraded my IntelliJ to version 6, the debugger is working very slow.
As a result, I had to stop using the debugger.
The problem is that when my application is connected to the debugger, it runs very slow. When I disconnect the debugger, it returns to run in its normal way.
Using previous versions of IntelliJ I didnt have this problem.
My environement:
XP; Xeon CPU (3.4GHz); 2.00 GB of RAM - no resources problem...
Any idea how I can get my debugger back?

3 comments
Comment actions Permalink

Hello Rachel,

RR> Since I have upgraded my IntelliJ to version 6, the debugger is
RR> working very slow.
RR>
RR> As a result, I had to stop using the debugger.
RR>
RR> The problem is that when my application is connected to the
RR> debugger, it runs very slow. When I disconnect the debugger, it
RR> returns to run in its normal way.
RR>
RR> Using previous versions of IntelliJ I didnt have this problem.
RR>
RR> My environement:
RR>
RR> XP; Xeon CPU (3.4GHz); 2.00 GB of RAM - no resources problem...
RR>
RR> Any idea how I can get my debugger back?

Please make sure that you don't have any method or conditional breakpoints
enabled. Because of JDI's limitations, they slow down debugging quite a lot.

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hi
I even tried to remove all breakpoints - didn't help.
Bye
Rachely

0
Comment actions Permalink

Please enable self-profiling like described here:
http://support.jetbrains.com/kb/entry.jspa?categoryID=5&externalID=192
and take several CPU snapshots while debugging the code. Please send these snapshots to me directly or attach to this thread.

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

"Rachel Romm" <Rachel_Romm@amat.com> wrote in message news:369165.1166080759936.JavaMail.itn@is.intellij.net...

Hi
I even tried to remove all breakpoints - didn't help.
Bye
Rachely



0

Please sign in to leave a comment.