Code completion short cut keys

Hi there

Turns out I've somehow set the code completion short cut that used to be CRTLSPACE to be CTRLWINDOWSKEY+SPACE. How do I change it back?

How do I turn it back on again?

Many kind regards

Message was edited by:
Rezrovs

5 comments
Comment actions Permalink

1. Pull up your Keymap configuration (File -> Settings -> Keymap)
2. Use the Shortcut Filter (Filter icon to the right of the search widget) to find the action you've bound the unwanted shortcut to. I'm guessing the action is basic code complete, which is located under Main Menu, Code, Complete Code, but the shortcut filter is a neat little feature that will find this for you.
3. Select the unwanted shortcut in the Shortcuts pane and click 'Remove'.

I would encourage you to dig around the various settings before posting these kinds of problems; there's no mystery here :) Any time you think 'there should be a way to do this...', there usually is. If you did give it a fair go before posting, please ignore this admonishment.

Cheers.

0
Comment actions Permalink

Hi there

Yes, I know about that keymap.

When I go into the key map, the setting still says that the shotcut is CTRLSPACE. Even though when I type that doesn't work. I still have to hit CTRLWINDOWS+SPACE to get the code completion to work.

So after I posted that last message I tried making a new active kepmap and changing the code complete shortcut to be anything else and then put it back to CTRLSPACE but for some reason it won't allow me to set it to CTRLSPACE and I'm still stuck with the closest thing being that plus the windows key.

(I should have updated the thread with that information)

I don't know how I did it, I've removed the settings folders, I've reinstalled intellij and I'm at a loss. If I can't get any luck here, I'll drop support an email.

Thanks,
Rachel

0
Comment actions Permalink

If anyone is interested or has the same problem, here is the answer

http://support.jetbrains.com/kb/entry.jspa?categoryID=21&externalID=195

0
Comment actions Permalink

Glad you found the solution.
Sorry about the undue harshness on my original reply.
Cheers.

0
Comment actions Permalink

No worries. I should have posted more informatio to not come across as a total noob.

Cheers,
Rachel

0

Please sign in to leave a comment.