No attribute auto-completion for Quipukit


In the Quipukit ( JSF component library, there are two files under the META-INF directory of the quipukit.jar archive:

1- quipuKit.tld, and
2- quipuKit-facelets.taglib.xml

Though that both of them share the same URI (, one is not a JSF TLD, but a Facelets TLD, so it should not be used to provide auto-completion support in JSF pages written in JSP format. But, in a JSP page, pressing Ctrl+B on

<%@ taglib prefix="q" uri="" %>

resolves to quipuKit-facelets.taglib.xml, and its side-effect is that IDEA cannot provide attribute-level auto-completion for the Quipukit components.

I configured a Resource mapping in the Settings -> Resources, but it didn't work and IDEA was still resolving to the quipuKit-facelets.taglib.xml. I removed quipuKit-facelets.taglib.xml from the JAR file, and IDEA was finally able to resolve the tld correctly.

Is this possibly a bug? Also, are there other workarounds (apart from removing quipuKit-facelets.taglib.xml from the JAR file) available to make attribute level auto-completion work again?


1 comment
Comment actions Permalink

I was able to resolve the issue by explicitly defining a taglib in the web.xml of my project, but having IDEA resolve the tld automagically would be great :)



Please sign in to leave a comment.