jsdom 4.x only works with io.js error (but I'm using io.js)

I'm trying to figure out how to load HTML documents into a Javascript object and get a DOM that I can manipulate. My original (poorly asked) question is at https://devnet.jetbrains.com/message/5543340


It looks like I need to use a package called jsdom

However, recent versions of jsdom requires one to use io.js rather than node.js

So I found and installed io.js and modified the preferences so that WebStorm is now using io.js as the interpreter

    /usr/local/var/nvm/versions/io.js/v2.0.2/bin/node

I then installed jsdom and tried to run a quick test. However, I immediately get the error

    jsdom 4.x onward only works on io.js, not Node.js

So for some reason, the jsdom code base seems to think that I'm still using nodejs as the interpreter rather than io.js

Anyone know what the problem is here?


Thanks,
D

1 comment
Comment actions Permalink

Never mind, I'll answer my own question.

Even though I changed the interpreter in the Node.js and NPM section of "Languages & Frameworks", it is still necessary to edit the configuration and change the interpreter there as well.

I don't quite understand this (and particularly why that configuration doesn't have a list of possible interpreters and requires you to enter the path/file to the interpreter) but it works now.

Rather than deleting my question, I figured I'd just answer it so that the next person who has this problem will find an easy answer.

0

Please sign in to leave a comment.