Console window in addition to IDEA window (build 807)

I haven't seen the additional console window (windows xp) next to the
IDEA window for a long time, but now in build 807 it is back. Is this
intended behaviour or some sort of "bug". In case it is intended to be
like this again, is there any option to switch it off?

Michael

14 comments

It's for debugging purposes. Stack traces and the like will be displayed
here, so that you can cut and past them in any problem reports you make.

"Michael Descher" <michael.descher@gmx.de> wrote in message
news:b5ih6q$6tj$1@is.intellij.net...

I haven't seen the additional console window (windows xp) next to the
IDEA window for a long time, but now in build 807 it is back. Is this
intended behaviour or some sort of "bug". In case it is intended to be
like this again, is there any option to switch it off?

>

Michael

>


0

Well, I did that - and still can do it - even better (at least in my
opinion) using the IDEA log file.

Michael

Paul Bradshaw wrote:

It's for debugging purposes. Stack traces and the like will be displayed
here, so that you can cut and past them in any problem reports you make.

"Michael Descher" <michael.descher@gmx.de> wrote in message
news:b5ih6q$6tj$1@is.intellij.net...

>>I haven't seen the additional console window (windows xp) next to the
>>IDEA window for a long time, but now in build 807 it is back. Is this
>>intended behaviour or some sort of "bug". In case it is intended to be
>>like this again, is there any option to switch it off?
>>
>>Michael
>>



0

You can turn them on by editing idea.lax file.

0

Oops, I meant "turn them off".

0

Edit idea.lax file by setting the following properties like this

  1. LAX.STDERR.REDIRECT

  2. -------------------

  3. leave blank for no output, "console" to send to a console window,

  4. and any path to a file to save to the file


lax.stderr.redirect=

  1. LAX.STDIN.REDIRECT

  2. ------------------

  3. leave blank for no input, "console" to read from the console window,

  4. and any path to a file to read from that file


lax.stdin.redirect=

  1. LAX.STDOUT.REDIRECT

  2. -------------------

  3. leave blank for no output, "console" to send to a console window,

  4. and any path to a file to save to the file


lax.stdout.redirect=

0

I've tried this on Windows 2000, and it doesn't work. I also tried commenting out the lines altogether. Has anyone gotten this to work under Windows?

0

Does not work on windows xp. I tried to use the idea.exe from build 804
which did not prevent the window either. Using the complete bin
directory from build 804 helps, though I don't know if this has other
unwanted side effects.

Michael

kesh wrote:

Edit idea.lax file by setting the following properties like this

  1. LAX.STDERR.REDIRECT

  2. -------------------

  3. leave blank for no output, "console" to send to a console window,

  4. and any path to a file to save to the file


lax.stderr.redirect=

  1. LAX.STDIN.REDIRECT

  2. ------------------

  3. leave blank for no input, "console" to read from the console window,

  4. and any path to a file to read from that file


lax.stdin.redirect=

  1. LAX.STDOUT.REDIRECT

  2. -------------------

  3. leave blank for no output, "console" to send to a console window,

  4. and any path to a file to save to the file


lax.stdout.redirect=


0

I use win2k too and the editing thingy doesn't work for me either :/

0

Michael,

Your post was enough of a clue for me to figure out a workaround. After a bit of trial and error, I figured out that in order to disable the lingering console window, you have to:

1) make the following edits in idea.lax:

lax.stdin.redirect=
lax.stdout.redirect=
lax.stderr.redirect=

2) overwrite idea.exe w/ the idea.exe from build 804. I stuck it on my website in case you overwrote your 804 install w/ 807 - http://www.geocities.com/ian_springer/idea.exe.bin

Judging by the symptoms, I suspect the idea.lax edits being ignored in 807 is due to a LaunchAnywhere bug. Hopefully, it will get fixed in an upcoming build.

--Ian

0

I thought I already tried this combination as well, but maybe I made
some mistake. I will give it another try. :)

Michael

Ian P. Springer wrote:

Michael,

Your post was enough of a clue for me to figure out a workaround. After a bit of trial and error, I figured out that in order to disable the lingering console window, you have to:

1) make the following edits in idea.lax:

lax.stdin.redirect=
lax.stdout.redirect=
lax.stderr.redirect=

2) overwrite idea.exe w/ the idea.exe from build 804. I stuck it on my website in case you overwrote your 804 install w/ 807 - http://www.geocities.com/ian_springer/idea.exe.bin

Judging by the symptoms, I suspect the idea.lax edits being ignored in 807 is due to a LaunchAnywhere bug. Hopefully, it will get fixed in an upcoming build.

--Ian


0

There is actually no way to hide console currently. We will provide such
ability in the next build.

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"

"Michael Descher" <michael.descher@gmx.de> wrote in message
news:b5ih6q$6tj$1@is.intellij.net...

I haven't seen the additional console window (windows xp) next to the
IDEA window for a long time, but now in build 807 it is back. Is this
intended behaviour or some sort of "bug". In case it is intended to be
like this again, is there any option to switch it off?

>

Michael

>


0

I take it you mean no official endorsed way. The method I described in my last post works like a charm for me.

0

I don't know why does it work for you but other people say it doen't.
Strange.

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"

"Ian P. Springer" <ian_springer@hp.com> wrote in message
news:14184896.1048531969036.JavaMail.jrun@is.intellij.net...

I take it you mean no official endorsed way. The method I described in my

last post works like a charm for me.
>


0

Please sign in to leave a comment.