WebStorm - How to disable auto delete on backspace

In Webstorm if you are in a code block and press enter on a line and it does an auto indent and you press backspace to remove the indent it automatically deletes the new line and goes back to the end of the previous line.  Is there some what to turn this off?

For example, if I have the following:

{
  // Some code here

and I press enter after "here" it will indent, but if I want to put a "}" there and press the backspace to remove the indent, it removes the line I just put in and takes me back to after "here".

2 comments

Hi there,

Settings (Preferences on Mac) | Editor | General | Smart Keys --> Backspace smart indent -- should help

3

THANK YOU!!!!!!!

That was the trick.

0

Please sign in to leave a comment.