ant property environment="env" not working in 804 on mac os x

I'm running 804 on os X with the final 1.4.1 from Apple. Almost everything is completely wonderful, except that I can't see my system enviroment variables inside Ant build files. For example, if I do something like this:


it doesn't work. The weird thing is that I have a separate drop of Ant that does this fine from the command line.


You will have access to all environment variables of a shell when you run idea via a shell script instead of using the '' launcher. Alternatively, you can add environment variable definitions to the file '.MacOSX/environment.plist' in your home directory.



Since I didn't have a shell script in the Mac version of Idea, I tried your plist idea. in ~/.MacOSX/environment.plist I put this:

CATALINA_HOME /var/tomcat4 JAVA_HOME /System/Library/Frameworks/JavaVM.framework/Home ]]>

And tried to access env.JAVA_HOME and env.CATALINA_HOME from Ant insided Idea, but that didn't work. Any ideas?



Oops, it works now. Somehow the environment.plist file I made before disappeared. But when I recreated it and logged in again, it all works.

Sorry for the false alarm. All is good now.



Please sign in to leave a comment.